imapd-ssl: couriertls: /etc/ssl/certs/edc85c27.0: No such file or directory

Discussion in 'Server Operation' started by 4700, Dec 23, 2010.

  1. 4700

    4700 New Member

    Hi there

    I've tried twice now to follow this guide: http://www.howtoforge.com/virtual-users-domains-postfix-courier-mysql-squirrelmail-debian-lenny

    Firstly, thanks to the author Falko for his efforts.

    Thinking I had made a mistake the first time, I blew everything away and followed the guide a second time. Both times however when attempting to use IMAP with SSL, it fails to authenticate and the only error in the log is:

    imapd-ssl: couriertls: /etc/ssl/certs/edc85c27.0: No such file or directory

    Of course edc85c27.0 doesn't exist in /etc/ssl/certs. Can anyone shed some light on how to fix such an error?

    Cheers!
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Is that file mentioned somewhere in your Courier configuration? I googled this error, but there was just one result, and it was a link to this thread...
     
  3. 4700

    4700 New Member

    No. I searched the entire server and the only reference to that filename is in the error log. I also created an empty file, gave it the exact same name displayed in the error log and saved it in /etc/ssl/certs to see if it would then generate a different error. The same error occurred, except this time the filename of the missing file changed in the error log.

    I'm currently using IMAP without SSL fine. Sending and receiving is perfect. I would however like to figure out what is causing this problem, and preventing me from using IMAP with SSL.

    My imapd-ssl config file is the default file installed during setup.
     
  4. danut.sun

    danut.sun New Member

    Hello,

    Do anyone know how to solve this problem? I follow this how to http://www.howtoforge.com/virtual-users-and-domains-with-postfix-courier-mysql-and-squirrelmail-ubuntu-12.10 and the IMAP SSL authentication do not work. I telnet from locahost on 993 port
    HTML:
    danut@danut-htpc:~$ telnet localhost 993
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    Connection closed by foreign host.
    
    and on syslog I get this error:

    HTML:
    Mar 28 16:26:14 danut-htpc imapd-ssl: couriertls: /etc/ssl/certs/395e6625.0: No such file or directory
    
    The similar error I receive when I telnet on 995 port for POP3.
     
  5. danut.sun

    danut.sun New Member

    I'm adding some new information:

    HTML:
    danut@danut-htpc:/var/log$ openssl s_client -connect localhost:993
    CONNECTED(00000003)
    write:errno=104
    ---
    no peer certificate available
    ---
    No client certificate CA names sent
    ---
    SSL handshake has read 0 bytes and written 226 bytes
    ---
    New, (NONE), Cipher is (NONE)
    Secure Renegotiation IS NOT supported
    Compression: NONE
    Expansion: NONE
    ---
    
     

Share This Page