imapd: Error reading ACLs for : Invalid argument

Discussion in 'Server Operation' started by tylerishappy, Oct 26, 2010.

  1. tylerishappy

    tylerishappy New Member

    I am recieving this error message every time I use Send / Received from Outlook.

    I have a Ubuntu Server setup with ISPConfig 3.0

    i have Outlook setup using IMAP



    /var/log/mail.err
    Oct 25 15:37:16 spider imapd: Error reading ACLs for : Invalid argument
    Oct 25 15:43:12 spider imapd: Error reading ACLs for : Invalid argument
    Oct 25 15:49:23 spider imapd: Error reading ACLs for : Invalid argument
    Oct 25 15:52:13 spider imapd: Error reading ACLs for : Invalid argument
    Oct 25 16:00:28 spider imapd: Error reading ACLs for : Invalid argument
    Oct 25 16:01:14 spider imapd: Error reading ACLs for : Invalid argument
    Oct 25 16:01:37 spider imapd: Error reading ACLs for : Invalid argument
    Oct 25 16:22:21 spider imapd: Error reading ACLs for : Invalid argument
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Do you use Courier or Dovecot? Did you set up any whitelist or blacklist records in ISPConfig?
     
  3. tylerishappy

    tylerishappy New Member

    Courier
    Just checked ISPConfig - no whitelist or blacklist
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Are you having problems fetching mails from the server?
     
  5. tylerishappy

    tylerishappy New Member

    I have the same account setup on multiple computers. On 1 of the computers I cannot send via my email address but I can receive. On the other 2 I can send and receive with no issues.

    The reason I found this issue is because I am trying to find out why I cannot send. I have double checked all of my account settings and they match to the other computers.
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Your IMAP daemon has nothing to do with sending emails. Are there any Postfix errors in your mail log?
     
  7. tylerishappy

    tylerishappy New Member

    Recent Mail Log

    user@spider:/var/log$ tail mail.log
    Oct 28 11:10:48 spider imapd: LOGOUT, user=user@emaildomain.com, ip=[::ffff:11.IPADDRESS.11], headers=0, body=0, rcvd=5835, sent=50115, time=67
    Oct 28 11:10:48 spider imapd: LOGOUT, user=user@emaildomain.com, ip=[::ffff:11.IPADDRESS.11], headers=0, body=0, rcvd=367, sent=10406, time=69
    Oct 28 11:10:48 spider imapd: LOGOUT, user=user@emaildomain.com, ip=[::ffff:11.IPADDRESS.11], headers=0, body=0, rcvd=122, sent=5147, time=67
    Oct 28 11:10:48 spider imapd: LOGOUT, user=user@emaildomain.com, ip=[::ffff:11.IPADDRESS.11], headers=0, body=0, rcvd=2934, sent=25821, time=48
    Oct 28 11:13:09 spider imapd: Connection, ip=[::ffff:11.IPADDRESS.11]
    Oct 28 11:13:10 spider imapd: LOGIN, user=user@emaildomain.com, ip=[::ffff:11.IPADDRESS.11], port=[51011], protocol=IMAP
    Oct 28 11:13:10 spider imapd: Error reading ACLs for : Invalid argument
    Oct 28 11:13:10 spider imapd: Connection, ip=[::ffff:11.IPADDRESS.11]
    Oct 28 11:13:10 spider imapd: LOGIN, user=user@emaildomain.com, ip=[::ffff:11.IPADDRESS.11], port=[51014], protocol=IMAP
    Oct 28 11:13:57 spider imapd: Error reading ACLs for : Invalid argument
    user@spider:/var/log$ tail mail.log
    Oct 28 11:13:57 spider imapd: Error reading ACLs for : Invalid argument
    Oct 28 11:15:00 spider imapd: LOGOUT, user=user@emaildomain.com, ip=[::ffff:11.IPADDRESS.11], headers=0, body=0, rcvd=5615, sent=49516, time=110
    Oct 28 11:15:01 spider imapd: LOGOUT, user=user@emaildomain.com, ip=[::ffff:11.IPADDRESS.11], headers=0, body=0, rcvd=5751, sent=49884, time=111
    Oct 28 11:15:01 spider imapd: Connection, ip=[::1]
    Oct 28 11:15:01 spider pop3d: Connection, ip=[::1]
    Oct 28 11:15:01 spider imapd: Disconnected, ip=[::1], time=0
    Oct 28 11:15:01 spider pop3d: Disconnected, ip=[::1]
    Oct 28 11:15:01 spider postfix/smtpd[30948]: connect from localhost[127.0.0.1]
    Oct 28 11:15:01 spider postfix/smtpd[30948]: lost connection after CONNECT from localhost[127.0.0.1]
    Oct 28 11:15:01 spider postfix/smtpd[30948]: disconnect from localhost[127.0.0.1]
     
    Last edited: Oct 28, 2010
  8. tylerishappy

    tylerishappy New Member

    Still cannot send email from the one account through the one server.
    - computer: Windows 7, Office 2007
    - Server: Ubuntu, ISPConfig 3
     
  9. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What are the outputs of
    Code:
    netstat -tap
    and
    Code:
    iptables -L
    ?
     
  10. tylerishappy

    tylerishappy New Member

    USER@spider:~$ sudo netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN 29635/mysqld
    tcp 0 0 *:http-alt *:* LISTEN 6181/apache2
    tcp 0 0 *:www *:* LISTEN 6181/apache2
    tcp 0 0 *:tproxy *:* LISTEN 6181/apache2
    tcp 0 0 *:ftp *:* LISTEN 22868/pure-ftpd (SE
    tcp 0 0 spider.(MYDOMAIN).co:domain *:* LISTEN 26377/named
    tcp 0 0 localhost:domain *:* LISTEN 26377/named
    tcp 0 0 *:ssh *:* LISTEN 29355/sshd
    tcp 0 0 localhost:953 *:* LISTEN 26377/named
    tcp 0 0 *:smtp *:* LISTEN 25464/master
    tcp 0 0 *:https *:* LISTEN 6181/apache2
    tcp 0 0 localhost:10024 *:* LISTEN 2182/amavisd (ch10-
    tcp 0 0 localhost:10025 *:* LISTEN 25464/master
    tcp 1 0 localhost:51913 localhost:mysql CLOSE_WAIT 30916/amavisd (ch10
    tcp 0 0 localhost:37662 localhost:mysql ESTABLISHED 2182/amavisd (ch10-
    tcp 0 0 localhost:mysql localhost:37662 ESTABLISHED 29635/mysqld
    tcp 0 52 spider.(MYDOMAIN).com:ssh h208-118-95-82.bi:32319 ESTABLISHED 12893/sshd: USER
    tcp6 0 0 [::]:pop3 [::]:* LISTEN 26291/couriertcpd
    tcp6 0 0 [::]:imap2 [::]:* LISTEN 26258/couriertcpd
    tcp6 0 0 [::]:ftp [::]:* LISTEN 22868/pure-ftpd (SE
    tcp6 0 0 [::]:domain [::]:* LISTEN 26377/named
    tcp6 0 0 [::]:ssh [::]:* LISTEN 29355/sshd
    tcp6 0 0 localhost:953 [::]:* LISTEN 26377/named
    tcp6 0 0 [::]:imaps [::]:* LISTEN 26280/couriertcpd
    tcp6 0 0 [::]:pop3s [::]:* LISTEN 26308/couriertcpd
     
  11. tylerishappy

    tylerishappy New Member

    USER@spider:~$ sudo iptables -L
    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    fail2ban-ssh tcp -- anywhere anywhere multiport dports ssh

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    Chain fail2ban-ssh (1 references)
    target prot opt source destination
    RETURN all -- anywhere anywhere
     
  12. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Looks ok. Are you sure you are connecting to the correct mail server with your email client?
     
  13. tylerishappy

    tylerishappy New Member

    I have recreated this account multiple times and it still does not work.

    I get the error every time i try to send email in my mail log:
    imapd: Error reading ACLs for : Invalid argument when sending email
     
: imap, mail, ubuntu

Share This Page