IMAP Thunderbird password not accepted

Discussion in 'Server Operation' started by Jayel, Oct 22, 2011.

  1. Jayel

    Jayel New Member

    I am running ISPConfig 3 on a server box at home and have setup a domain and mailbox, I have IMAP & IMAPs setup and can send and receive email via Squirrelmail by logging in without a problem

    When I am trying to setup Thunderbird it automatically detects the IMAP service and asks for my email and password. I have entered in the details 100% correct but I am getting a failed to login message when sending login information.

    I have checked my local mail log and the below is the output (x.x.x.x is my ip and I have changed my email to [email protected]):

    Code:
    Oct 22 18:03:09 jayel postfix/smtpd[7769]: warning: x.x.x.x: address not listed for hostname bebox.config
    Oct 22 18:03:09 jayel postfix/smtpd[7769]: connect from unknown[x.x.x.x]
    Oct 22 18:03:09 jayel postfix/smtpd[7769]: improper command pipelining after EHLO from unknown[x.x.x.x]
    Oct 22 18:03:09 jayel postfix/smtpd[7769]: disconnect from unknown[x.x.x.x]
    Oct 22 18:03:09 jayel postfix/smtpd[7769]: warning: x.x.x.x: address not listed for hostname bebox.config
    Oct 22 18:03:09 jayel postfix/smtpd[7769]: connect from unknown[x.x.x.x]
    Oct 22 18:03:09 jayel postfix/smtpd[7769]: disconnect from unknown[x.x.x.x]
    Oct 22 18:03:10 jayel imapd-ssl: Connection, ip=[::ffff:x.x.x.x]
    Oct 22 18:03:10 jayel pop3d-ssl: couriertls: accept: error:14094412:SSL routines:SSL3_READ_BYTES:sslv3 alert bad certificate
    Oct 22 18:03:10 jayel imapd-ssl: LOGOUT, ip=[::ffff:x.x.x.x], rcvd=24, sent=468
    Oct 22 18:03:10 jayel pop3d-ssl: Unexpected SSL connection shutdown.
    Oct 22 18:03:54 jayel imapd: Connection, ip=[::ffff:x.x.x.x]
    Oct 22 18:03:54 jayel imapd: LOGIN FAILED, method=PLAIN, ip=[::ffff:x.x.x.x]
    Oct 22 18:03:59 jayel imapd: LOGIN FAILED, user=jayel, ip=[::ffff:x.x.x.x]
    Oct 22 18:04:04 jayel imapd: Disconnected, ip=[::ffff:x.x.x.x], time=10, starttls=1
    Oct 22 18:04:04 jayel imapd: Connection, ip=[::ffff:x.x.x.x]
    Oct 22 18:04:04 jayel imapd: LOGIN, [email protected], ip=[::ffff:x.x.x.x], port=[58115], protocol=IMAP
    Oct 22 18:04:05 jayel imapd: LOGOUT, [email protected], ip=[::ffff:x.x.x.x], headers=0, body=0, rcvd=10, sent=80, time=1, starttls=1
    Oct 22 18:04:07 jayel imapd: Connection, ip=[::ffff:x.x.x.x]
    Oct 22 18:04:07 jayel imapd: LOGIN FAILED, method=PLAIN, ip=[::ffff:x.x.x.x]
    Oct 22 18:04:12 jayel imapd: LOGIN FAILED, user=jayel, ip=[::ffff:x.x.x.x]
    Oct 22 18:05:01 jayel pop3d: Connection, ip=[::ffff:127.0.0.1]
    Oct 22 18:05:01 jayel pop3d: Disconnected, ip=[::ffff:127.0.0.1]
    Oct 22 18:05:01 jayel imapd: Connection, ip=[::ffff:127.0.0.1]
    Oct 22 18:05:01 jayel imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
    Can anyone tell from this what might be going wrong?
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. Jayel

    Jayel New Member

    Indeed I was, thank you for that although this has leaded to a more interesting problem.

    Now Thunderbird has connected, it has picked up the folders in the mailbox and synchronised all of my mail. This confuses me because.....

    When I try to send a mail from my gmail account to my server it gets returned with the following error:

    The error that the other server returned was: 550 550 Administrative prohibition (state 14).

    On checking my mail.log:

    Code:
    Oct 24 19:22:03 jayel imapd: Connection, ip=[::ffff:127.0.0.1]
    Oct 24 19:22:03 jayel imapd: LOGIN, [email protected], ip=[::ffff:127.0.0.1], port=[59906], protocol=IMAP
    Oct 24 19:22:03 jayel imapd: LOGOUT, [email protected], ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=87, sent=391, time=0
    I can't see any error message here at all.

    And when I try to send from my server using Thunderbird it states login has failed and on checking my mail.log

    Code:
    Oct 24 19:29:45 jayel postfix/smtpd[13480]: connect from unknown[x.x.x.x]
    Oct 24 19:29:45 jayel postfix/smtpd[13480]: warning: unknown[x.x.x.x]: SASL PLAIN authentication failed: no mechanism available
    Oct 24 19:29:45 jayel postfix/smtpd[13480]: warning: unknown[x.x.x.x]: SASL LOGIN authentication failed: no mechanism available
    Oct 24 19:29:57 jayel postfix/smtpd[13480]: disconnect from unknown[x.x.x.x]
    
    I don't understand why it is an unknown as I have double checked the Thunderbird settings and I have definitely entered them correctly.

    Totally confused about whats happening here, any advice would be appreciated greatly.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Which distribution do you use?

    Also, please check if your domain's MX record points to your server:

    Code:
    dig mx yourdomain.com
     
  5. Jayel

    Jayel New Member

    Hey im using Ubuntu Server 11.10 and yes after a bit more googling it was my MX record for my first issue and I have managed to amend it.

    The second is still causing me a problem, here is my main.cf file

    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    readme_directory = /usr/share/doc/postfix
    
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    myhostname = myserver.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = localhost, localhost.localdomain
    relayhost = 
    mynetworks = 127.0.0.0/8 [::1]/128
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    html_directory = /usr/share/doc/postfix/html
    virtual_alias_domains = 
    virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_mailbox_base = /var/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    smtpd_sasl_auth_enable = yes
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
    smtpd_tls_security_level = may
    transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
    relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
    smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
    smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
    maildrop_destination_concurrency_limit = 1
    maildrop_destination_recipient_limit = 1
    virtual_transport = maildrop
    header_checks = regexp:/etc/postfix/header_checks
    mime_header_checks = regexp:/etc/postfix/mime_header_checks
    nested_header_checks = regexp:/etc/postfix/nested_header_checks
    body_checks = regexp:/etc/postfix/body_checks
    content_filter = amavis:[127.0.0.1]:10024
    receive_override_options = no_address_mappings
    message_size_limit = 0
    So now I can update my client with mails from the server, I can receive emails but cannot send from a client. Definitley a postfix/smtp issue, any other config files helpful to get to the bottom of this issue?
     
  6. Jayel

    Jayel New Member

    Last edited: Oct 25, 2011
  7. falko

    falko Super Moderator ISPConfig Developer

Share This Page