IMAP SSL gmail

Discussion in 'ISPConfig 3 Priority Support' started by ruliezz, Dec 2, 2016.

  1. ruliezz

    ruliezz Member HowtoForge Supporter

    A lot of client complain that there external mail account in gmail doenst work.
    I have test it with a new account and its true. If you select port 993 then you get a error: "SSL error: unable to verify the first certificate".
    Nothing is change about the SSL cert, the only thing what I did was update ISPConfig. I dont understand what is going wrong.

    I have restore dovecot.conf from a backup, but still its not working.
    Yes it works perfect in Thunderbird and Webmail (roundcube) works fine as well.

    Any thoughts?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The error message indicate that you have a problem with an ssl certificate:

    1) Ensure that the ssl certificate is really valid for the domain / subdomain that you use as imap server name in the gmail settings.
    2) Add a intermediate ssl certifcate if required for your ssl cert in dovecot config file.
     
  3. ruliezz

    ruliezz Member HowtoForge Supporter

    Right, I have checked almost everything.. but what is the right config option to do that then I will try that.
    it's quite weird because other mail client except from Gmail seems to work so I looking blind on the issue.. maybe it's so simple.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    From dovecot website: http://wiki.dovecot.org/SSL/DovecotConfiguration

    S what does it mean? you enter the ssl cert first and then the ssl bundle file(s), all in the same file.
     
  5. ruliezz

    ruliezz Member HowtoForge Supporter

    I have installed the SSL correct I think, now I get this error @ Gmail.
    "Missing +OK response upon connecting to the server: * OK [CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID ENABLE IDLE AUTH=PLAIN AUTH=LOGIN] Dovecot (Ubuntu) ready."
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Any errors in the mail.log when gmail tries to connect to your server?
     
  7. ruliezz

    ruliezz Member HowtoForge Supporter

    @till mail.log no new rules. Only in syslog:

    Dec 5 14:51:45 webpanel dovecot: imap-login: Disconnected (no auth attempts in 1 secs): user=<>, rip=209.85.161.146, lip=XX.XX.XX.XX, TLS: Disconnected, session=<AwedlulC2QDRVaGS>
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok. and using a normal imap mail client like thunderbird with tls is working for that account?
     
  9. ruliezz

    ruliezz Member HowtoForge Supporter

    Its weird that Google use TLS if we use a SSL port. And yes, that account allows imap.
     

Share This Page