imap ssl cert

Discussion in 'Installation/Configuration' started by Dy0nisus, Feb 27, 2007.

  1. Dy0nisus

    Dy0nisus New Member

    Hello again :)

    I tried to generate a new ssl cert for my IMAPD courier ...

    I used

    Code:
    mkimapdcert
    after removing the old imapd.pem

    I also edited

    Code:
    /etc/courier/imapd.cnf
    As I can see a Cert is generated with the right Parameters. But if
    i connect via imap to the mailserver the cert is again for localhost with
    all old Parameters.

    Do I have to edit another Parameter - File?

    best regards
     
  2. falko

    falko Super Moderator

    Which distribution do you use? What did you change in /etc/courier/imapd.cnf? What's in that file now?
     
  3. Dy0nisus

    Dy0nisus New Member

    Hi Falko!

    I'm using debian 3.1 sarge

    I just replaced the given Parameters for

    Code:
    [ req_dn ]
    C=DE
    ST=Hamburg
    L=Hamburg
    O=HCS
    OU=Webhosting
    CN=mail.myhighclass.de
    emailAddress=webmaster@myhighclass.de
    
     
  4. falko

    falko Super Moderator

    The file looks ok.
    Maybe mkimapdcert takes some parameters. Did you check out
    Code:
    man mkimapdcert
    ?
     
  5. Dy0nisus

    Dy0nisus New Member

    i looked at the manpage again and there are no specified parameter exept the content of imapd.cnf

    if i execute mkimapdert i get this output:

    Code:
    Generating a 1024 bit RSA private key
    ...................++++++
    ........++++++
    writing new private key to '/usr/lib/courier/imapd.pem'
    -----
    1024 semi-random bytes loaded
    Generating DH parameters, 512 bit long safe prime, generator 2
    This is going to take a long time
    ..+..................+....................................................................+...++*++*++*++*++*++*
    subject= /C=DE/ST=Hamburg/L=Hamburg/O=HighClass.Services/OU=Webhosting/CN=mail.myhighclass.de/emailAddress=webmaster@myhighclass.de
    notBefore=Mar  2 13:45:18 2007 GMT
    notAfter=Mar  1 13:45:18 2008 GMT
    
    as u can see, the parameters of imapd.cnf are correct ...

    now i deleted imapd.pem and restarted courier-imapd ...

    then i connected to the server and i can see, that its again the std - cert ..

    no warning or error with the missing imapd.pem ?!
     
  6. Dy0nisus

    Dy0nisus New Member

    i'm stupid ... sorry

    after looking at imap-ssl - config - file i copied the new imapd.pem
    to the right location and now it works ...

    sorry for wasting ure time :(
     

Share This Page