IMAp/SMTP connect from smartphone

Discussion in 'Technical' started by Ovidiu, Sep 17, 2006.

  1. Ovidiu

    Ovidiu Active Member

    hi guys,

    I recently got myself a new Nokia E70 and set it up to read emails from my server via IMAP and send with smtp.
    I managed to set it up to use ssl/tls but did not get it working with smtp secure authenticattion, then I started fiddling around with the phone settings and now nothing works...

    One problem I had was, when connecting it said: untrusted certificate or unvalid or whatever cfertificate found, which I had to accept as in the details I could see it was the courier(I guess) certificate that was being generated by my server. but this problem I will sove by browsing the nokia forums and learn how to import a certificate into the phone.

    The phone does this: it connects to my wireless lan or via GPRS/EDGE and then tries to get my mails. Right now it says: conecting to mailbox and my whole phone freezes....

    I am pretty sure its not a phone problem so I need some help how to debug this and get the right settings for my phone or whatever IMAP software I could use on my windows pc to test the connection.

    to sum it up:

    a) can you suggest a free and small IMAP email client with logging capabilities for winxp so I can test the settings
    b) can you tell me which logs (on the server) to monitor during my test to see if there are errors?
    c) can someone give me the right settings (including ports) to use with the phone/software

    right now I am at a loss, I am so furious as nothing works anymore and I simply do not know why, I just do not know where to start, I just need soem hints to get started with this thing...

    thx in advance for any help
  2. falko

    falko Super Moderator ISPConfig Developer

    The mail logs are in /var/log.
    IMAP uses port 143, IMAPS port 993.
  3. Ovidiu

    Ovidiu Active Member

    thx, is there an easy way for testing different settings from a windows pc? the problem is testing from the phone does cost (if not using wireless lan) and takes a while..

    the last results are these: using imap port 143 everything is ok. when I try ssl/tls port 993 my phone freezes. It used to work because some days ago it asked me to accept the untrusted certificate but right now it just freezes... any idea where to look for the error? which logfile? what else can I test?
    Last edited: Sep 18, 2006
  4. falko

    falko Super Moderator ISPConfig Developer

    If you're on Debian, it's /var/log/mail.log.

Share This Page