Imap Login failed

Discussion in 'Installation/Configuration' started by TomC, Jan 19, 2010.

  1. TomC

    TomC New Member

    Hi folks,

    having used ISPConfig 2 for quite some time, I have now set up my first server with ISPConfig 3. Quite some new things to learn, but it looks great, so far.

    However, I am running into problems when trying to do an IMAP connection with Thunderbird to a newly created mailbox. While Thunderbird simply says that the connection failed, I have the following entries in the mail.info logfile:
    Code:
    Jan 19 20:37:24 matrux imapd-ssl: Connection, ip=[::ffff:91.49.229.157]
    Jan 19 20:37:26 matrux imapd-ssl: LOGIN FAILED, method=PLAIN, ip=[::ffff:91.49.229.157]
    Jan 19 20:37:31 matrux imapd-ssl: LOGIN FAILED, user=abcdefg, ip=[::ffff:91.49.229.157]
    Jan 19 20:37:55 matrux imapd-ssl: Disconnected, ip=[::ffff:91.49.229.157], time=31, starttls=1
    This doesn't say too much. But is there any place where I can dig deeper into what happened?

    Any help is greatly appreciated!

    Best regards,
    Tom
     
  2. till

    till Super Moderator

    Which Linux distribution? Which perfect server guide did you used for the install? Was this a fresh and empty system or did you had ispconfig 2 installed on it before?
     
  3. TomC

    TomC New Member

    Hi Till,

    thanks for replying so quickly.

    * I am running the server on Debian 4.0 - 2.6.9-023stab051.3-smp, a vserver.
    * I used the text-based install guide on http://ispconfig.org/docs/INSTALL_DEBIAN_4.0.txt
    * I installed on 6th of January 2010 from svn.
    * There was no old ispconfig on the system - it was a completely blank Debian installation.

    Best regards,
    Tom
     
  4. till

    till Super Moderator

    If this server is a production system, then dont use the SVN Version. SVN versions are only for developers and simply might not work as they are untested and not released. You should uninstall ispconfig and reinstall the latest stable version (3.0.1.6).
     
  5. TomC

    TomC New Member

    Ok, i'll try the stable version.

    Can you give me a pointer to an "complete uninstall guide" for ISPconfig 3?
     
  6. till

    till Super Moderator

    Run the uninstall script which is inside the install dierctory of the ispconfig tar.gz.
     
  7. TomC

    TomC New Member

    Hi Till,

    well, now I uninstalled ISPconfig 3, deleted the ispconfig user in the DB and reinstalled the whole thing from the newest tar.gz file.

    Unfortunately I get the same error as before. Thunderbird cannot login via imap to the users mailbox.

    Errors in mail.info are the same as in my first posting.

    So, what might be wrong?!

    Tom
     
  8. till

    till Super Moderator

    And you are sure that you used the complete email address to login? ISPConfig 3 is different then ispconfig 2, it uses virtual users and you have to login with the email address and password of the mailbox to imap, pop3 and smtp.
     
  9. TomC

    TomC New Member

    Aaaargh!!!! Why didn't anybody tell me??? ;-)))

    Well, it worked! Of course, it worked!

    This brings me to the point where I would like to ask for pointers to documentation of ISPConfig 3. There is so much material about ISPConfig 2, but I have a hard time to find information on Version 3. No users manual, no introduction... or did I miss out on something? Where could I have read about the user-issue?

    Anyway, thanks for your help. I really appreciate this.
     
  10. till

    till Super Moderator

    There are no manuals available for ispconfig 3 yet.
     
  11. TomC

    TomC New Member

    ;-) at lease I did not miss out on that one!

    So, I have to ask you even more stuff... sorry, about that.

    1. It looks like you defined three Webserver-Ports. Port 80 for the standard user websites. Port 8080 for ispconfig admin interface. And port 8081 for apps - whatever that means. Well, I tried to use phpmyadmin via the apps-port by setting a softlink in /var/www/apps - that didn't work, because I obviously don't have permissions to access the index.php. So firstly, is the 8081-server meant for things like this? And secondly, what did I do wrong?

    2. When apache is (re-)started I get the following error messages:

    Code:
    root@matrux:# /etc/init.d/apache2 restart
    Forcing reload of web server (apache2)...[Wed Jan 20 12:01:55 2010] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    [Wed Jan 20 12:01:55 2010] [error] VirtualHost _default_:8081 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    [Wed Jan 20 12:01:55 2010] [warn] NameVirtualHost *:8081 has no VirtualHosts
     waiting [Wed Jan 20 12:01:57 2010] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    [Wed Jan 20 12:01:57 2010] [error] VirtualHost _default_:8081 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    [Wed Jan 20 12:01:57 2010] [warn] NameVirtualHost *:8081 has no VirtualHosts
    
    When I edit the default file in the sites-available directory by changing NameVirtualHost * to NameVirtualHost *:80, the first error is gone, but I can't access the ISPConfig admin interface anymore, because I get re-routed to the apache "It works!" message. So, what's wrong here?

    Thanks again for your help!

    Greetz,
    Tom
     
  12. till

    till Super Moderator

    1) The problem is that you used a svn version first which reconfigured your system. The apps part is under development and not finished yet and there are no apps available.

    2) Also related to the fact that you installed a svn version first.

    You will have to find all occurences of port 8081 in your apache config and vhost files and remove them.
     
  13. TomC

    TomC New Member

    Ok, so I deleted the apps.vhost file and the link in sites-enabled. Correct?

    The 8081 errors are gone now, but the port 80 errors are still there:

    Code:
    Forcing reload of web server (apache2)...[Wed Jan 20 12:36:13 2010] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
     waiting [Wed Jan 20 12:36:15 2010] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    
    Oh, and it doesn't solve my problem on how to link in with phpmyadmin.


    Another issue: After some configuration I logged off from the admin console, tried to login again and get an error "Username or Password wrong." However, the admin user is still in the sys_user table (with whatever password - after all its encrypted..). What strange kind of error is that?


    Once again thank you so much for your patience and great help!!!

    Tom
     
  14. till

    till Super Moderator

    The warnings woith port 80 are ok.

    Regarding the password error, you can set a new password with phpmyadmin, it may be encrypted with md5 or crypt-md5.
     

Share This Page