IMAP Authentication Error

Discussion in 'ISPConfig 3 Priority Support' started by Matthias Reich, Sep 15, 2019.

Tags:
  1. Matthias Reich

    Matthias Reich New Member HowtoForge Supporter

    Hello,
    I'm unable to login into roundcube and a "Login Failed" error appears. I've created different mailboxes but to no avail.
    This is the log file of roundcube:
    [27-Aug-2019 11:43:06 +0200]: <bt2tdo8f> IMAP Error: Login failed for [email protected] from 123.456.78.9. AUTHENTICATE PLAIN: Authentication failed. in /usr/share/roundcube/program/lib/Roundcube/rcube_imap.php on line 196 (POST /squirrelmail/?_task=login&_action=login)
    For mail logs: tail -f /var/log/mail.log
    Sep 15 15:48:07 bbcp postfix/smtpd[701]: connect from kunden.mms-webhosting.de[88.198.225.203]
    Sep 15 15:48:08 bbcp postfix/smtpd[2874]: warning: hostname mobiup.climberjumbo.com does not resolve to address 141.98.9.195
    Sep 15 15:48:08 bbcp postfix/smtpd[2874]: connect from unknown[141.98.9.195]
    Sep 15 15:48:09 bbcp postfix/smtpd[701]: warning: kunden.mms-webhosting.de[88.198.225.203]: SASL PLAIN authentication failed:
    Sep 15 15:48:09 bbcp postfix/smtpd[701]: lost connection after RSET from kunden.mms-webhosting.de[88.198.225.203]
    Sep 15 15:48:09 bbcp postfix/smtpd[701]: disconnect from kunden.mms-webhosting.de[88.198.225.203] ehlo=1 auth=0/1 rset=1 commands=2/3
    Sep 15 15:48:15 bbcp postfix/smtpd[2874]: warning: unknown[141.98.9.195]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
    Sep 15 15:48:16 bbcp postfix/smtpd[2874]: disconnect from unknown[141.98.9.195] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
    Sep 15 15:48:23 bbcp postfix/smtpd[701]: warning: hostname suffil.rostage.com does not resolve to address 141.98.9.5
    Sep 15 15:48:23 bbcp postfix/smtpd[701]: connect from unknown[141.98.9.5]
    Sep 15 15:48:30 bbcp postfix/smtpd[701]: warning: unknown[141.98.9.5]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
    Sep 15 15:48:31 bbcp postfix/smtpd[701]: disconnect from unknown[141.98.9.5] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
    Sep 15 15:48:43 bbcp postfix/smtpd[2874]: warning: hostname jukyo.yountrol.com does not resolve to address 141.98.9.42
    Sep 15 15:48:43 bbcp postfix/smtpd[2874]: connect from unknown[141.98.9.42]
    Sep 15 15:48:50 bbcp postfix/smtpd[2874]: warning: unknown[141.98.9.42]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
    Sep 15 15:48:50 bbcp postfix/smtpd[2874]: disconnect from unknown[141.98.9.42] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
    Sep 15 15:49:02 bbcp postfix/smtpd[701]: warning: hostname mobiup.climberjumbo.com does not resolve to address 141.98.9.195
    Sep 15 15:49:02 bbcp postfix/smtpd[701]: connect from unknown[141.98.9.195]
    Sep 15 15:49:06 bbcp postfix/smtpd[2874]: connect from kunden.mms-webhosting.de[88.198.225.203]
    Sep 15 15:49:08 bbcp postfix/smtpd[2874]: warning: kunden.mms-webhosting.de[88.198.225.203]: SASL PLAIN authentication failed:
    Sep 15 15:49:08 bbcp postfix/smtpd[2874]: lost connection after RSET from kunden.mms-webhosting.de[88.198.225.203]
    Sep 15 15:49:08 bbcp postfix/smtpd[2874]: disconnect from kunden.mms-webhosting.de[88.198.225.203] ehlo=1 auth=0/1 rset=1 commands=2/3
    Sep 15 15:49:09 bbcp postfix/smtpd[701]: warning: unknown[141.98.9.195]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
    Sep 15 15:49:09 bbcp postfix/smtpd[701]: disconnect from unknown[141.98.9.195] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
    Sep 15 15:49:09 bbcp postfix/smtpd[2874]: warning: hostname suffil.rostage.com does not resolve to address 141.98.9.5
    Sep 15 15:49:09 bbcp postfix/smtpd[2874]: connect from unknown[141.98.9.5]
    Sep 15 15:49:19 bbcp postfix/smtpd[2874]: warning: unknown[141.98.9.5]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
    Sep 15 15:49:19 bbcp postfix/smtpd[2874]: disconnect from unknown[141.98.9.5] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
    Sep 15 15:49:23 bbcp dovecot: imap-login: Disconnected (auth failed, 1 attempts in 2 secs): user=<[email protected]>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured, session=<8m0jwZeSrox/AAAB>

    Any ideas what's going wrong?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    roundcube connects to localhost normally, I wonder why you don't have any connects from localhost in the log.

    Which tutorials did you use to set up this server and did you modify any settings in RoundCube?
    Do logins with other email clients work?
     
  3. Matthias Reich

    Matthias Reich New Member HowtoForge Supporter

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Restart dovecot and check if you get any errors in the mail.log from the restart.
     
  5. Matthias Reich

    Matthias Reich New Member HowtoForge Supporter

    Here's the last few lines of code:
    Sep 16 10:11:06 bbcp postfix/smtpd[32318]: connect from kunden.mms-webhosting.de[88.198.225.203]
    Sep 16 10:11:08 bbcp postfix/smtpd[32318]: warning: kunden.mms-webhosting.de[88.198.225.203]: SASL PLAIN authentication failed:
    Sep 16 10:11:08 bbcp postfix/smtpd[32318]: lost connection after RSET from kunden.mms-webhosting.de[88.198.225.203]
    Sep 16 10:11:08 bbcp postfix/smtpd[32318]: disconnect from kunden.mms-webhosting.de[88.198.225.203] ehlo=1 auth=0/1 rset=1 commands=2/3
    Sep 16 10:11:18 bbcp dovecot: master: Warning: SIGHUP received - reloading configuration
    Sep 16 10:11:18 bbcp dovecot: config: Warning: /etc/dovecot/dovecot.conf line 67: Global setting mail_plugins won't change the setting inside an earlier filter at /etc$
    Sep 16 10:11:18 bbcp dovecot: config: Warning: /etc/dovecot/dovecot.conf line 67: Global setting mail_plugins won't change the setting inside an earlier filter at /etc$
    Sep 16 10:11:18 bbcp postfix/smtpd[32318]: warning: hostname s.lz6.zl.sampa.br does not resolve to address 185.36.81.245: Name or service not known
    Sep 16 10:11:18 bbcp postfix/smtpd[32318]: connect from unknown[185.36.81.245]
    Sep 16 10:11:20 bbcp postfix/smtpd[577]: connect from unknown[45.125.65.34]
    Sep 16 10:11:21 bbcp postfix/smtpd[32318]: warning: unknown[185.36.81.245]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
    Sep 16 10:11:21 bbcp postfix/smtpd[32318]: lost connection after AUTH from unknown[185.36.81.245]
    Sep 16 10:11:21 bbcp postfix/smtpd[32318]: disconnect from unknown[185.36.81.245] ehlo=1 auth=0/1 commands=1/2
    Sep 16 10:11:22 bbcp postfix/smtpd[577]: warning: unknown[45.125.65.34]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
    Sep 16 10:11:22 bbcp postfix/smtpd[577]: lost connection after AUTH from unknown[45.125.65.34]
    Sep 16 10:11:22 bbcp postfix/smtpd[577]: disconnect from unknown[45.125.65.34] ehlo=1 auth=0/1 commands=1/2
    Sep 16 10:11:24 bbcp dovecot: master: Warning: Processes aren't dying after reload, sending SIGTERM.
    Sep 16 10:11:24 bbcp dovecot: master: Warning: Sent SIGTERM to 1 auth processes
    Sep 16 10:11:24 bbcp dovecot: auth: Warning: Killed with signal 15 (by pid=1045 uid=0 code=kill)
    Sep 16 10:11:29 bbcp dovecot: master: Warning: SIGHUP received - reloading configuration
    Sep 16 10:11:29 bbcp dovecot: config: Warning: /etc/dovecot/dovecot.conf line 67: Global setting mail_plugins won't change the setting inside an earlier filter at /etc$
    Sep 16 10:11:29 bbcp dovecot: config: Warning: /etc/dovecot/dovecot.conf line 67: Global setting mail_plugins won't change the setting inside an earlier filter at /etc$
    Sep 16 10:11:35 bbcp dovecot: master: Warning: Processes aren't dying after reload, sending SIGTERM.
    Sep 16 10:11:35 bbcp dovecot: master: Warning: Sent SIGTERM to 1 auth processes
    Sep 16 10:11:35 bbcp dovecot: auth: Warning: Killed with signal 15 (by pid=1045 uid=0 code=kill)
    Sep 16 10:11:47 bbcp postfix/anvil[1496]: statistics: max connection rate 2/60s for (smtp:88.198.225.203) at Sep 16 10:11:06
    Sep 16 10:11:47 bbcp postfix/anvil[1496]: statistics: max connection count 1 for (smtp:185.234.219.72) at Sep 16 10:02:44
    Sep 16 10:11:47 bbcp postfix/anvil[1496]: statistics: max cache size 5 at Sep 16 10:11:20
    Sep 16 10:11:48 bbcp postfix/smtpd[32318]: connect from unknown[141.98.10.60]
    Sep 16 10:11:49 bbcp postfix/smtpd[577]: warning: hostname cata4.atacado.sampa.br does not resolve to address 185.36.81.16: Name or service not known
    Sep 16 10:11:49 bbcp postfix/smtpd[577]: connect from unknown[185.36.81.16]
    Sep 16 10:11:50 bbcp postfix/smtpd[32318]: warning: unknown[141.98.10.60]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
    Sep 16 10:11:50 bbcp postfix/smtpd[32318]: lost connection after AUTH from unknown[141.98.10.60]
    Sep 16 10:11:50 bbcp postfix/smtpd[32318]: disconnect from unknown[141.98.10.60] ehlo=1 auth=0/1 commands=1/2
    Sep 16 10:11:51 bbcp postfix/smtpd[577]: warning: unknown[185.36.81.16]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
    Sep 16 10:11:51 bbcp postfix/smtpd[577]: lost connection after AUTH from unknown[185.36.81.16]
    Sep 16 10:11:51 bbcp postfix/smtpd[577]: disconnect from unknown[185.36.81.16] ehlo=1 auth=0/1 commands=1/2
    Sep 16 10:12:08 bbcp postfix/smtpd[32318]: warning: hostname s.lz1.zl.sampa.br does not resolve to address 185.36.81.232: Name or service not known
    Sep 16 10:12:08 bbcp postfix/smtpd[32318]: connect from unknown[185.36.81.232]
    Sep 16 10:12:10 bbcp postfix/smtpd[32318]: warning: unknown[185.36.81.232]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
    Sep 16 10:12:10 bbcp postfix/smtpd[32318]: lost connection after AUTH from unknown[185.36.81.232]
    Sep 16 10:12:10 bbcp postfix/smtpd[32318]: disconnect from unknown[185.36.81.232] ehlo=1 auth=0/1 commands=1/2
    Sep 16 10:13:03 bbcp dovecot: imap-login: Disconnected (tried to use unsupported auth mechanism): user=<>, method=CRAM-MD5, rip=127.0.0.1, lip=127.0.0.1, secured, sess$
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if roundcube tried to use CRAM-MD5 which is not supported, roundcube should have used plain or login as auth method. Please run the command:

    grep -r imap_auth_type /etc/roundcube/

    The message "Warning: /etc/dovecot/dovecot.conf line 67: Global setting mail_plugins won't change the setting inside an earlier filter at" can be ignored.
     
  7. Matthias Reich

    Matthias Reich New Member HowtoForge Supporter

    I did that & nothing changed. So I did a reboot and now I get a connection refused.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Connection refused in which service?
     
  9. Matthias Reich

    Matthias Reich New Member HowtoForge Supporter

  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if apache is not stated then. Start apache2 and start dovecot:

    systemctl start apache2
    systemctl start dovecot

    This whole topic is quite unusual and to me, it seems as if there must have gone something really wrong during install, was the system clean and empty when you started, no services except ssh installed? Or your server has not enough RAM? Did you check the /var/log/syslog for errors?
     
  11. Matthias Reich

    Matthias Reich New Member HowtoForge Supporter

    The server has enough RAM. The syslog seems fine to me. I restarted nginx and that was fixed but I still can't login to the mail. Should I PM you the access if you could check it please?
    Running that command gives me
    /etc/roundcube/defaults.inc.php:$config['imap_auth_type'] = 'auth';

    I've been breaking my head for the second day now.
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Try change that line to:

    $config['imap_auth_type'] = null;

    as that's what is used in the system which has been installed with the debian 10 perfect server nginx here.
     
  13. Matthias Reich

    Matthias Reich New Member HowtoForge Supporter

    Done and rebooted but still doesn't work. I'm unable to login from anywhere - not just RoundCube so is it possible that I've to change something else as well?
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Please send me a pm with the root and ispconfig admin login details so I can have a look at the system.
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    The actual problem was that there were no maildirs created. I checked this in the database and noticed that the mail domain had a server_is 0, which is impossible as you have to select I mail server when you create the domain. My guess is that you did this: You either created the server without enabling mail services in expert mode or you manually disabled the mail service under system > server services. Then you created the email domain without having a mail service, that's the only way to get a mail domain with an ID 0 which basically means this mail domain is not located on any server. Then you later enabled mail services again on your server, so there was a mail server again but this will not affect your existing test domain as you can not move a domain from a non-existing system to another server. A mailbox inherits the server_id from its mail domain, this means that all mailboxes had a wrong server_id as well. In addition to that, you did not had the current ISPConfig version installed and dependency of amavisd was missing, which I installed and update now.

    I created a test domain and it is working fine. You have to delete your test email domain in ispconfig and create a new one. The new one will be working then. And do not disable mail services on your server when you want to use mail services.
     
  16. Matthias Reich

    Matthias Reich New Member HowtoForge Supporter

    I don't remember disabling it at all. Thanks for all your help. You saved my day!
     
  17. Matthias Reich

    Matthias Reich New Member HowtoForge Supporter

    Oh and when I'm sending to Gmail I'm getting a mail returned to sender. Any idea what could be the issue in my case?
     
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    Gmail tells you in the returned email why they rejected it.
     
  19. Matthias Reich

    Matthias Reich New Member HowtoForge Supporter

    host
    gmail-smtp-in.l.google.com[2a00:1450:400c:c00::1a] said: 550-5.7.1
    [2a01:4f8:c2c:4393::1] Our system has detected that this message does
    550-5.7.1 not meet IPv6 sending guidelines regarding PTR records and
    550-5.7.1 authentication. Please review 550-5.7.1
    https://support.google.com/mail/?p=IPv6AuthError for more information 550
    5.7.1 . s13si22537695wrn.139 - gsmtp (in reply to end of DATA command)

    Is this a DNS issue?
     
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, but not a dns issue of your domain, it's a dns issue of the IPv6 address. Your IPv6 address has no reverse record. The PTR of the IP address and IPv6 address is normally set in the user panel of the datacenter where you rented your server.
     

Share This Page