Imagick and additional PHP Versions

Discussion in 'HOWTO-Related Questions' started by stephanl, Mar 21, 2014.

  1. stephanl

    stephanl New Member

  2. srijan

    srijan New Member HowtoForge Supporter

    Hi

    Paste the output of this

    Br//
    Srijan
     
  3. stephanl

    stephanl New Member

    Hi,

    /usr/lib/php5/20100525/imagick.so

    Thanks!
     
  4. srijan

    srijan New Member HowtoForge Supporter

    Hi

    Pleas reinstall imagick



    Br//
    Srijan
     
  5. stephanl

    stephanl New Member

    This did not resolv the problem. Do you have any other idea?
     
  6. srijan

    srijan New Member HowtoForge Supporter

    Please search this package
    Br//
    Srijan
     
  7. stephanl

    stephanl New Member

    Hi!

    He did not find anything. Do you have any idea why?
     
  8. srijan

    srijan New Member HowtoForge Supporter

    Please run:

    Br//
    Srijan
     
  9. stephanl

    stephanl New Member

    HI sirihan,

    thats the output:

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package libmagick9-dev is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    However the following packages replace it:
    graphicsmagick-libmagick-dev-compat

    E: Unable to locate package libmagick10
    E: Package 'libmagick9-dev' has no installation candidate
     
  10. srijan

    srijan New Member HowtoForge Supporter

    Hi

    Do one thing go for debugging of ISPConfig from link

    Then run it as root.

    Br//
    Srijan
     
  11. stephanl

    stephanl New Member

    Did do it. This is the output:

    PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/ming.ini on line 1 in Unknown on line 0
    10.04.2014-15:44 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    10.04.2014-15:44 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    finished.

    Any ideas? Thank you!
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    The debian package php5-imagick is for the main php from debian only, it is not for the additional php versions. if you want to use imagemagick from a additional php version, then you will have to reconfigure php to enable this module and then recompile php.
     
  13. stephanl

    stephanl New Member

    Last edited: Apr 10, 2014
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    yes. First go to the compile directory:

    cd /usr/local/src/php5-build/php-5.3.22

    then run

    make clean

    to clenaup your last compile action. then run:

    ./configure --help

    to get all compile options. there should be a option to enable imagemagick. I dont knkow the exact option, so you have to look it up.

    then redor the configure and compile step fom the guide, but add the additiona option, mots likely:

    --enable-imagemagick \

    between the other options. It dont matter where, just dont add it at the end. then run configure again and finally make and make install.
     
  15. stephanl

    stephanl New Member

    Hi till,

    thank you for that explanation. In the list from "--help" there is no imagick/imagemagick option. Do I do anything wron?
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    ok, then it might be that its just a pecl extension. try this:

    cd /opt/phpfcgi-5.3.28/etc
    pecl -C ./pear.conf update-channels
    pecl -C ./pear.conf install imagick

    if this works, then you will have to add a line like this:

    extension=imagick.so

    in /opt/phpfcgi-5.3.28/lib/php.ini and restart apache.
     
  17. stephanl

    stephanl New Member

    Great, did work, thank you!
     

Share This Page