ImageMagick update on Debian Etch

Discussion in 'Installation/Configuration' started by stephanl, Jul 26, 2009.

  1. stephanl

    stephanl New Member

    Hi,

    I have one problem by using ImageMagick with Imagick, if I try to call

    PHP:
    Imagick::roundCorners()
    the following error occures:

    I found out that IM in version >=6.2.9 is required.

    But there is no package avaluable with a higher version than I use for Debian Etch. So I decided to install IM in a higher version by myself and have done this:

    Code:
    wget ftp://ftp.imagemagick.org/pub/ImageMagick/ImageMagick.tar.gz
    tar xfvz ImageMagick.tar.gz
    cd ImageMagick-6.5.4-5
    ./configure --prefix=/usr/local/ImageMagick-6.5.4-5 --with-quantum-depth=8 --with-gs-font-dir=/usr/share/fonts --with-windows-font-dir=/usr/share/fonts/windows --with-imagick
    make
    make install
    Now everything is installed in

    But if I type

    Code:
    which convert
    the path to the old (apt-get installed) ImageMagick-Version is given. How can I change this and do I have to update Imagick, too?

    Thanks a lot in advance
    Stephan

    PS: If I call the roundCorners command now, the same error occures (of course).
     
  2. falko

    falko Super Moderator ISPConfig Developer

    You can add this to your ~/.bashrc file:
    Code:
    PATH="/usr/local/ImageMagick-6.5.4-5/bin:$PATH"
     
  3. stephanl

    stephanl New Member

    Hi!

    thank you for your answer! But that doesn't solve the problem.

    For everyone with the same issue, I worked a few hours and here is a solution:

    - unistall php5-imagick and imagemagick via apt-get remove.
    - Install imagemagick like I did (commands in my first post)
    - uninstall the pecl package for imagemagick and install the new version, then install php5-imagick via apt-get install (or install php5-imagick at first? not sure in which order)

    That was how I figured it out. Hope it helps.

    Kind regards
    Stephan
     
  4. Kev King

    Kev King New Member

    Was having problems with installing 6.5.4-6, and I read this post, but was not confident of the commands that stephanl, quoted,not being up on cmd line stuff and what it all meant. Have had more down time than up thru bad typying :(

    Anyway I found a good source of info at the following, via the imagmagick forum:

    http://www.digitalsanctum.com/2009/03/18/installing-imagemagick-from-source-on-ubuntu-804/

    I am on Debian5.02(lenny) and the install worked a dream. I think the errors I was getting were because I didnt remove the older version first but hey all working now.

    Just thought i would share this, just in case someone else was having the same problems, and it might save someone alot of arsing about.
     

Share This Page