I'm not able to use FTP access.

Discussion in 'Installation/Configuration' started by nevermindtbc, Jun 17, 2010.

  1. nevermindtbc

    nevermindtbc New Member

    SOLVED - I'm not able to use FTP access.

    Hi
    I'm running ubuntu 10 server and followed the tutorial on this site for install for ISPConfig3.

    I have setup a new ftp client and website, these are both working. I have also made sure that there is a ftp usr also. However when I attemp to get access useing filezilla I am given an error;

    Code:
    Status:	Connecting to 192.168.0.12:21...
    Status:	Connection established, waiting for welcome message...
    Response:	220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Response:	220-You are user number 1 of 50 allowed.
    Response:	220-Local time is now 16:11. Server port: 21.
    Response:	220-This is a private system - No anonymous login
    Response:	220-IPv6 connections are also welcome on this server.
    Response:	220 You will be disconnected after 15 minutes of inactivity.
    Command:	USER si81
    Response:	331 User si81 OK. Password required
    Command:	PASS ******
    Response:	530 Login authentication failed
    Error:	Critical error
    Error:	Could not connect to server
    I can connect by ssh and outcome of netstat -tap | grep ftp is
    Code:
    tcp        0      0 *:ftp                   *:*                     LISTEN      12854/pure-ftpd (SE
    tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      12854/pure-ftpd (SE
    Alos enabled verbose logging in pure-ftp

    Code:
    Jun 17 16:11:12 simalpas pure-ftpd: (?@192.168.0.2) [INFO] New connection from 192.168.0.2
    Jun 17 16:11:17 simalpas pure-ftpd: (?@192.168.0.2) [WARNING] Authentication failed for user [si81]
    Jun 17 16:11:17 simalpas pure-ftpd: (?@192.168.0.2) [INFO] Logout.
    
    I know i put the correct password in, also I can login to the FTP with my system user account.

    Seem to have a similar problem to clammy77

    No idea why I can't connect.

    Thanks in advance for your help, I'm sure I'm doing something stupid.
     
    Last edited: Jun 18, 2010
  2. till

    till Super Moderator

    A FTP username in ISPConfig looks like c0... or c1..., so you did not use the correct full FTP username. It must be something like c0si81. Please look into the FTP users list, you can see the username there.
     
  3. nevermindtbc

    nevermindtbc New Member

    I've look in the interface under FTP-Users and it lists the user name as si81,

    I've tried adding on a c0 through to c6 (the client with the user name si is client 3)

    Still no joy, if i put in my ssh login details though filezilla displays the file system. Could pure-ftp be looking at the wrong user table?
     
  4. till

    till Super Moderator

    Thats a good point for further investigation. If you are able to login with a SSH user, the pure-ftpd is not connected to the mysql database, instead it authenticates against /etc/passwd which is not the correct authentication method for virtual FTP users.

    There are 4 different pure-ftpd packages available:

    pure-ftpd-ldap - Pure-FTPd FTP server with LDAP user authentication
    pure-ftpd-mysql - Pure-FTPd FTP server with MySQL user authentication
    pure-ftpd-postgresql - Pure-FTPd FTP server with PostgreSQL user authentication
    pure-ftpd - Pure-FTPd FTP server

    The one that has to be installed is:

    pure-ftpd-mysql

    the other ones will not work. At the moment, you seem to have installed pure-ftpd without mysql bindings. Please run:

    apt-get install pure-ftpd-mysql

    to install the one with mysql bindings.
     
  5. nevermindtbc

    nevermindtbc New Member

    Hi, thanks for the help so far.

    I've just tried reinstalling pure-ftpd-mysql, and also checked that mysql is running. Both seem to be fine.

    Checking in mysql dbispconfig is present and under ftp_user the user si81 is listed. For some reason pure-ftp doesn't seem to be connecting to mysql, but I have no idea how to fix this.

    Sorry to be a pain.


    edit: ISPConfig shows mysql as enabled in the monitor tab
     
    Last edited: Jun 17, 2010
  6. till

    till Super Moderator

    First, try to run:

    rm /etc/pure-ftpd/db/mysql.conf~

    and restart pure-ftpd and try to login again. If this does not help, post the output of:

    ls -la /etc/pure-ftpd/auth

    and the file

    /etc/pure-ftpd/db/mysql.conf

    (remove the line MYSQLPassword .... before you post the file).
     
  7. nevermindtbc

    nevermindtbc New Member

    Thanks for all the help.

    I managed to accidentally delete mysql.conf so decided to reinstall everything, now ftp seems to be working. I just can't get the default webpage off apache default and point to an ISPConfig defalut page. I'll keep looking into it, I'm sure I'll find the answer some where (damn dyndns!)
     

Share This Page