I'm an IDIOT

Discussion in 'Installation/Configuration' started by normdouglas, Jul 30, 2007.

  1. normdouglas

    normdouglas New Member

    I have put myself in a real problem.

    Been running ISPCONFIG for sometime without issue. I had to rebuild my laptop which naturally wiped all my caches, and I forgot to save my Firefox Bookmarks which had the URL to my ISPCONFIG admin page.

    My ISPCONFIG box sits on my LAN. I know it's IP, and I know the user and pass, I also know the hostname but I don't know the URL to get to it. Sounds stupid I know.

    I have been googling for hours and know it has something to do with the config.inc.php and or the httpd.conf and now that i have tried many different combinations to try and rectify it I am completely lost.

    Can I reset/reconfigure this area of ISPCONFIG? I know I can still see all the users etc through WEBMIN and have full control over the box, but I want my ISPCONFIG control panel back.

    Can someone help?
  2. edge

    edge Active Member Moderator

    did you try http://the_lan_ip_of_server:81 or if you used https https://the_lan_ip_of_server:81, or am I missing here something?

    If you want to use the domainname instead of IP, login with the IP URL, and goto Management > Settings. In Domain, you will see the main domainname ISConfig is listening to.
    Last edited: Jul 30, 2007
  3. normdouglas

    normdouglas New Member

    Yes, tried that but still doesn't work

    I know the PORT number I have used during setup, (800) and i know the IP, but I cannot connect.

    Could someone please tell me PRECISELY what should be in /root/ispconfig/httpd/conf/httpd.conf and what should be in /home/admispconfig/ispconfig/lib/config.inc.php in the server section given the following information I know : IP = PORT = 800

  4. larwilliams

    larwilliams New Member

    In "/root/ispconfig/httpd/conf/httpd.conf", try to find something similar to the following (this is what I found in mine)
    # Port: The port to which the standalone server listens. For
    # ports < 1023, you will need httpd to be run as root initially.
    Port 81
    Listen 81
    Those last 2 lines tell what port your ISPConfig is listening on.

    Or you can look at "/home/admispconfig/ispconfig/lib/config.inc.php", and see if there is something like the following under "System Settings":
      $go_info["server"]["server_url"] = 'http://'.$_SERVER['HTTP_HOST'];
    } else {
      $go_info["server"]["server_url"] = "http://www.domain.ca:81";
    The $go_info["server"]["server_url"] lines will tell you how to access your ISPConfig via browser. The 2nd one is generally the easiest.
  5. normdouglas

    normdouglas New Member

    Don't know why

    Thanks for your replies, what I did was change it from 800 (which I had set in install ages ago) back to 81 and hey presto. Must have been something to do with my network stopping 800, even though I am access it via a LAN.


Share This Page