If termcap is obsolete, why does asterisk configure require it?

Discussion in 'Installation/Configuration' started by ecsd, Nov 28, 2007.

  1. ecsd

    ecsd New Member

    * buy the o'reilly asterisk book
    * download the source
    * On the latest Ubuntu, run "configure" for Asterisk and it says

    No support for termcap, fatal, goodbye.

    Run "./configure --help" and it says it supports a flag "--without-termcap" so I say

    ./configure --without-termcap

    and it fails the same way, saying "no support for termcap, can't proceed."

    When I look around for how to make available the thing asterisk DEMANDS, all I find is old documentation and something that explains how termcap is obsolete - but NOTHING to PROVIDE IT ANYWAY so I CAN COMPILE ASTERISK.

    If termcap is obsolete and GNU has Nothing to provide it on Linux ANYWAY and especially since Asterisk was prototyped primarily on Linux - then WHY CAN I NOT COMPILE ASTERISK FOR LACK OF A THING THAT NOBODY USES AND NOBODY PROVIDES?

    So I ask if someone knows how to get past this? But I also strongly recommend that Asterisk reviews its makefiles and GETS RID OF the requirement for things that CANNOT BE FOUND. Their book doesn't even begin to suggest that this would be an issue - it's not covered in the "if compilation fails" - it means that 100.000 % of everyone buying the Asterisk book trying to compile on any Linux (other than CentOS apparently) will run into the SAME PROBLEM.

    Thanks for your attention.

    ==

    Ubuntu provides Asterisk in packages, but some details are hidden so I wanted to start from source. Besides which it should just compile, anyway.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What happens when you leave out --without-termcap?
     
  3. ecsd

    ecsd New Member

    re: asterisk versus termcap

    I ran "configure" without arguments in the first place and it complained it needed termcap (and quit.) So I asked it what its options were and "--without-termcap" was at least implied if not stated; I ran "configure --without-termcap" and it failed in Exactly the same way. So, "configure" isn't honoring that without-termcap flag.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Seems the configure help is outdated. Have you tried --disable-termcap instead?
     

Share This Page