I think country code for my country is wrong in ssl ispconfig 3

Discussion in 'Installation/Configuration' started by lonerunner, Apr 7, 2013.

  1. lonerunner

    lonerunner Member

    Well i just got positivessl from namecheap but i can't set it. When i try to add certificate on namecheap website i get error

    "CS" is not a valid ISO-3166 country code!

    When i want to add certificate request on namecheap for my website i go to my ispconfig 3 controlpanel and in my website under ssl i generate ssl and select ssl request to add it to positivessl but i get error from above.

    I did little search and on wikipedia

    CS code is known as Serbia and montenegro but this is obsolete now because Serbia and Montenegro are no longer together. So for my country Serbia, country code is RS or SRB.

    And in ispconfig on ssl website tab i don't have option to select Serbia in country list, only Serbia and Montenegro so my guess is that ispconfig 3 still use old country code for my country and i can't get ssl now from namecheap.

    How can i update this, or change somehow manually to get proper ssl request code in my ispconfig so i can get positivessl verification from namecheap.
  2. falko

    falko Super Moderator ISPConfig Developer

    I've added this to our bugtracker, so we will check that.
  3. lonerunner

    lonerunner Member

    Is there a way that i can generate csr manually in meantime?
  4. falko

    falko Super Moderator ISPConfig Developer

    I've just fixed this in SVN.
  5. lonerunner

    lonerunner Member

    Sorry for late answering but i was bit busy i just recently updated ispconfig Big Thanks it's working now, i got the certificate from Positive SSL but now problem is that i don't know how to set it up, the files that i got from SSL provider are domain.tld.crt PositiveSSLCA2.crt and AddTrustExternalCARoot.crt while files on my domain ssl are different so i don't know how to set it up. Ill make a new topic if someone can help me with that as this is not part of this topic and the issue with country code is resolved.

Share This Page