I think Cloudflare is blocking 8080 on https

Discussion in 'General' started by schwim, Aug 6, 2019.

  1. schwim

    schwim Member

    Hi there folks,

    I set up Cloudflare on my server and although https://server.mysite.com:8080 worked for almost 24 hours, my browser now reports:
    https://mysite.com and https://server.mysite.com still work and since the only thing I've changed is the Cloudflare setup, I searched through the docs for that and came across this:
    and I note that 8080 is not supported via HTTPS.

    Can I ask what the preferred solution would be to getting me back into my ispConfig panel?

    Thanks!
     
  2. Jesse Norell

    Jesse Norell Well-Known Member

    In a brief search I find the same page you referenced, which sounds to me like they simply don't support https on 8080. You could ssh to your server and reconfigure ISPConfig (via update.php) to run on port 8443. Other options are to run ISPConfig in a named vhost on port 443 vhost, or setup a port 443 named vhost which proxies to 8080. If only you need access, or you have very few (and very flexible) customers, you could even use ssh port forwarding or a vpn type tunnel to access ISPConfig.
     

Share This Page