I need some help with my first LAMP

Discussion in 'Server Operation' started by beckteck, Dec 17, 2009.

  1. beckteck

    beckteck New Member

    okay, I have
    Ubuntu Linux 8.04.3 LTS
    Postfix
    Dovecot

    The server has been up and running since mid NOV. and running well.

    But I have one issue that I know of.
    Mail Warn log
    warning: do not list domain domain.net in BOTH mydestination and virtual_alias_domains

    It also has a duplicate listing for another domain on the server, but only the two report on this log as entries

    I have been working on this for a week(not solid) and if remove domain.net, as well as the other domain, it will bounce the emails to those domains. with
    <[email protected]> (expanded from <[email protected]>): User unknown in virtual alias table

    I have tried several things, and just can't seem to figure it out. With this being my first linux period, lett alone web server, I am afraid I do not have the experience.

    Everytime I create a new user(through virtualmin) it actually creates two. example=[email protected]+XX-domain.net
    This may be a non issue, but again, I don't know.

    My main.cf:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version


    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    readme_directory = no

    # TLS parameters
    smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
    smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
    smtpd_use_tls=yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_local_domain = domain.net
    smtpd_recipient_restrictions = permit_mynetworks,permit_sasl_authenticated,reject_unauth_destination
    smtpd_sasl_security_options = noanonymous

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.

    myhostname = mail.domain.net
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = webserver, localhost, localhost.beckteck.net
    mydestination = btwebserver, localhost, domain.net
    mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    virtual_alias_maps = hash:/etc/postfix/virtual

    and my /etc/postfix/virtual:
    [... long list of email addresses mapped to system accounts ... --> edited by sjau]


    Any insight would be great.
    If possible I would like to fix this and not just start all over. It is in production as we speak

    Thanks
    S
     
    Last edited: Feb 22, 2010
  2. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    Code:
    postconf -n | grep virtual_alias_domains
    and
    Code:
    postconf -d | grep virtual_alias_domains
    ?
     
  3. beckteck

    beckteck New Member

    output files

    postconf -n | grep virtual_alias_domains
    -No output-
    postconf -d | grep virtual_alias_domains
    $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks
    virtual_alias_domains = $virtual_alias_maps

    Thanks for the reply
    --S
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Please try this:
    add the line
    Code:
    [email protected] info-beckteck.net
    to /etc/postfix/virtual, run
    Code:
    postmap /etc/postfix/virtual
    , remove beckteck.net from the mydestination line in /etc/postfix/main.cf and restart Postfix.
     
  5. beckteck

    beckteck New Member

    Had no effect, still get a undeliverable mail reply to the sender.
    This server will add @domain.net to all incoming mail to some but not all domains if they are not listed in the main.cf. it will add to at least two out of four.

    Thanks
    Scott
     
    Last edited: Feb 22, 2010
  6. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your mail log?
     
  7. beckteck

    beckteck New Member

    Dec 21 09:11:12 btwebserver postfix/error[8298]: 8FDDA3424E: to=<[email protected]>, orig_to=<[email protected]>, relay=none, delay=0.35, delays=0.24/0.03/0/0.08, dsn=5.0.0, status=bounced (User unknown in virtual alias table)
     
    Last edited: Feb 22, 2010
  8. beckteck

    beckteck New Member

    there was another error that I found in the mail.err log

    Dec 21 09:07:33 btwebserver postfix/postmap[7861]: fatal: open /etc/postfix/virtual.db: Permission denied
     
  9. mandelbrot

    mandelbrot New Member

    Can you confirm permissions on /etc/postfix/virtual?

    Code:
    ls -lA /etc/postfix 
     
  10. beckteck

    beckteck New Member

    permissions for /etc/postfix/virtual.db is set at 0644

    Thanks
     
  11. mandelbrot

    mandelbrot New Member

    User and group?
     
  12. beckteck

    beckteck New Member

    user - root
    group - root
     
  13. mandelbrot

    mandelbrot New Member

    According to http://bliki.rimuhosting.com/space/knowledgebase/linux/mail/postfix notes:

    Missing virtual.db File

    Getting an error like:

    fatal: open database /etc/postfix/virtual.db: No such file or directory
    warning: process /usr/libexec/postfix/smtpd pid 27552 exit status 1
    warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling

    Then you need to create virtual.db file.

    Run

    postmap virtual

    from /etc/postfix.

    IIRC RHEL4's postfix startup script re-creates the virtual.db file so you should not hit this unless you are on some other distro (e.g. Debian?) ​
    [/INDENT]
     
    Last edited: Dec 22, 2009
  14. beckteck

    beckteck New Member

    Good News

    I think I have it figured out on the main.cf and virtual

    I logged into webmin and went to the postfix config. found this

    Rewrite "user" to "user@$mydomain" it was set to yes.

    I set it to no, commented out my old $mydestination and put in new
    mydestination = btwebserver, localhost, localhost.beckteck.net

    Thank you for everything on this, I may come back for some more issues, and will mark this solved after a few days of no issues

    Thanks a lot guys
     

Share This Page