I have to wait more than 10 minutes for ISPConfig to create a website?

Discussion in 'General' started by todx, Jul 26, 2012.

  1. todx

    todx New Member

    Hey everyone. I've noticed I always have a problem adding new website into ISPConfig system. Whenever I make a new website, database for it, ftp for it and DNS zone, I always have to wait 15+ minutes, sometimes 30minutes? Why is that? Can I do anything to prevent this or speed it up or does ISPConfig normal take so long to process the data?

    thanks in advance
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Normally it takes about one minute to write the configuration to disk. Maybe a lock file of the server process has not been removed correctly, run:

    rm -f /usr/local/ispconfig/server/temp/.ispconfig_lock

    to remove it. If the problem happend again, then there is a problem with your server or system configuration that causes the server process to die. Debugging instructions for the server process can be found in the faq.
     
  3. cfoe

    cfoe ISPConfig Developer ISPConfig Developer

    I have the same problem on my servers.

    The /usr/local/ispconfig/server/temp/.ispconfig_lock file was there. I removed it but no solution for the problem :mad:

    Where can the debug guide be found?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Last edited: Jul 27, 2012
  5. todx

    todx New Member

    THANK YOU till!!!

    I did what you said and it only took around 10 seconds for the newly created website, ftp, database and DNS to become active!

    PERFECT SOLUTION! (at least for me =))

    Thanks again!

    EDIT: ** Should I remove it more often? Or is this once in a year problem? =) I've been using ISPConfig for 6 months now.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    I did not had it yet on my servers that a lock file was not deleted, so I guess it wont happen that often. But if there is a problem with the php installation or any of the applications that get called by ispconfig, it might happen that the php process dies again and can not remove the lock file. In that case, you should try to debug the issue to find the reason for the hanging process.
     
  7. todx

    todx New Member

    Thank you for the information till, I was away that's why I didn't answer. You say I should debug this issue? Can you refer me to a guide or tutorial on how to debug such issues?
     
  8. MaddinXx

    MaddinXx Member HowtoForge Supporter

    Hey,

    You have to: ISPConfig -> System -> Server Config (take server which has problems) -> Server -> Loglevel = Debug

    Afterwards you can do a

    Code:
    tail -f /var/log/ispconfig/ispconfig.log
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    See post #4 in this thread.
     
  10. todx

    todx New Member

    Command "/usr/local/ispconfig/server/server.sh" returned:

    Code:
    PHP Warning:  PHP Startup: apc.shm_size now uses M/G suffixes, please update your ini files in Unknown on line 0
    And after that "finish".

    I bought this would affect the php in any way? Or is this serious?

    NOTE: I tried to fix it, by adding "M" or "G" at the end of "apc.shm_size=512", how ever that didn't seem to make any effect.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Did the problems start before you installed apc or after yu installed apc? On my servers, I use xcache instead of apc, makes less problems.
     
  12. todx

    todx New Member

    I'm certain I installed apc "after" I installed the server via tutorial here on howtoforge.com, so basically the apc cannot be the reason why I had the ".ispconfig_lock" file. Other than apc I don't get any errors.
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    The opposite of your conclusion is the case, if you installed apc after ispconfig, then apc can be the reason for your problem. You should disable apc and ensure that you did not disable any functions in php.ini file.
     
  14. todx

    todx New Member

    I want to disable it to see if the problems go away however I can't, since I have 50+ users using apc on RoundCube to send attachments. Any other suggestions?

    Also, I was reading articles on the internet and it was never mentioned apc would destory/kill/hang apache process, in your words "system configuration that causes the server process to die", since apc is the only problem I got from debugging. Could there be anything else wrong?
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Not quite sure were you searched.If I enter "apc php" in the search field in the forum, then there are several threads related to hanging processes caused by apc. But if you cant replace it with another cache, then its not a option to remove it.

    There can be other thingsa s well that are set wrong in the php.ini like disabled functions. See my posts above. Also it seems that you still havent enabled debugging like it is described in the FAQ, otherwise you would have recieved verbose output.
     
  16. todx

    todx New Member

    Oh sorry, I have no idea how I missed that step, here is the output in which the lock file gets removed:

    Code:
    07.08.2012-09:37 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    07.08.2012-09:37 - DEBUG - No Updated records found, starting only the core.
    07.08.2012-09:37 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    finished
     
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats ok and the lock files was removed correctly. Please rerun the server.sh script at a time were the minute can be divided by 5, so "minute/5=0" as the monitor part runs only every 5 minutes.
     
  18. todx

    todx New Member

    This is what I got:

    Code:
    07.08.2012-09:55 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    07.08.2012-09:55 - DEBUG - No Updated records found, starting only the core.
    /usr/sbin/mpt-status
    /usr/bin/fail2ban-client
    /sbin/iptables
    /sbin/ip6tables
    07.08.2012-09:55 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    finished.
    Beside that output I still have the apc problem at the top of the output:

    Code:
    PHP Warning:  PHP Startup: apc.shm_size now uses M/G suffixes, please update your ini files in Unknown on line 0
    
     
  19. falko

    falko Super Moderator ISPConfig Developer

    Did you fix it in the correct place? PHP settings can be in php.ini or be set individually for a website (e.g. through ISPConfig or inside an .htaccess file).
     
  20. todx

    todx New Member

    So I went to check each and every .htaccess file on my server to see if there are any apc settings inside and I found nothing. So because I know that I'm using RoundCube that uses apc, I went to check some tutorials on where to find those .htaccess files, so I found them and there was no mentioning of apc.

    So basically I have no idea why that error keeps poping up and my only solution to this problem would be to completely remove apc from my server.

    If any of you guys come across any other ideas, please let me know.
     

Share This Page