I have this Failed to install the automatic package ISPCONFIG.

Discussion in 'Installation/Configuration' started by Wotan6891, Mar 19, 2022.

  1. Wotan6891

    Wotan6891 New Member

    Hello,

    there attach the images where I take a picture of the steps. and the error it gives me.

    when it gives me the message, I write "YES", then that's where I get those vertical Y's towards the bottom.

    I hope someone has gone through this and can enlighten me.

    Thank you.
     

    Attached Files:

  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Can you cut and paste the text of the commands and responses you get? It would be easier to understand what happens, those screenshots of text screens just confuse.
    Trying to make sense of this thread, are you using ISPConfig autoinstaller with these instructions: https://www.howtoforge.com/ispconfig-autoinstall-debian-ubuntu/
     
  3. Wotan6891

    Wotan6891 New Member

    hello,

    and so it is, I am using that tutorial that you mentioned, which is the most current, for Debian 11.
    https://www.howtoforge.com/ispconfig-autoinstall-debian-ubuntu/

    then I do all the steps until I enter this:

    Code:
    wget -O - https://get.ispconfig.org | sh -s -- --help
    then it gives me these results:

    Code:
    [email protected]:~# wget -O - https://get.ispconfig.org | sh -s -- --help
    --2022-03-19 14:57:48--  https://get.ispconfig.org/
    Resolviendo get.ispconfig.org (get.ispconfig.org)... 104.26.11.246, 172.67.75.112, 104.26.10.246, ...
    Conectando con get.ispconfig.org (get.ispconfig.org)[104.26.11.246]:443... conectado.
    Petición HTTP enviada, esperando respuesta... 200 OK
    Longitud: 2004 (2,0K) [application/octet-stream]
    Grabando a: «STDOUT»
    
    -                   100%[===================>]   1,96K  --.-KB/s    en 0s   
    
    2022-03-19 14:57:49 (40,2 MB/s) - escritos a stdout [2004/2004]
    
    
    
    ********************************************************************************ISPConfig 3 Autoinstaller
    ********************************************************************************
    
    Usage: ispc3-ai.sh [<argument>] [...]
    
    This script automatically installs all needed packages for an ISPConfig 3 setup using the guidelines from the "Perfect Server Setup" howtos on www.howtoforge.com.
    
    
    Possible arguments are:
        --help          Show this help page
        --debug         Enable verbose logging (logs each command with the exit
                        code)
        --channel       Choose the channel to use for ISPConfig.
                        --channel=<stable|dev>
                        "stable" is the latest ISPConfig release available on
                        www.ispconfig.org
                        "dev" is the latest dev-branch from the ISPConfig git
                        repository:
                        https://git.ispconfig.org/ispconfig/ispconfig3/tree/develop
                        -> The dev channel might contain bugs and less-tested
                        features and should only be used in production by very
                        experienced users.
        --lang          Use language for ISPConfig installation. Specify with
                        --lang=en|de (only en (English) and de (German) supported
                        currently).
        --interactive   Don't install ISPConfig in non-interactive mode. This is
                        needed if you want to use expert mode, e. g. to install a
                        slave server that shall be integrated into an existing
                        multiserver setup.
        --use-nginx     Use nginx webserver instead of apache2
        --use-amavis    Use amavis instead of rspamd for mail filtering
        --use-unbound   Use unbound instead of bind9 for local resolving. Only
                        allowed if --no-dns is set.
        --use-php       Use specific PHP versions, comma separated, instead of
                        installing multiple PHP, e.g. --use-php=7.4,8.0 (5.6, 7.0,
                        7.1, 7.2, 7.3, 7.4, 8.0 and 8.1 available).
                        --use-php=system disables the sury repository and just
                        installs the system's default PHP version.
                        ommiting the argument (use all versions)
        --use-ftp-ports This option sets the passive port range for pure-ftpd. You
                        have to specify the port range separated by hyphen, e. g.
                        --use-ftp-ports=40110-40210.
                        If not provided the passive port range will not be
                        configured.
        --use-certbot   Use Certbot instead of acme.sh for issuing Let's Encrypt
                        certificates. Not adviced unless you are migrating from a
                        old server that uses Certbot.
        --no-web        Do not use ISPConfig on this server to manage webserver
                        setting and don't install nginx/apache or pureftpd. This
                        will also prevent installing an ISPConfig UI and implies
                        --no-roundcube as well as --no-pma
        --no-mail       Do not use ISPConfig on this server to manage mailserver
                        settings. This will install postfix for sending system
                        mails, but not dovecot and not configure any settings for
                        ISPConfig mail. It implies --no-mailman.
        --no-dns        Do not use ISPConfig on this server to manage DNS entries.
                        Bind will be installed for local DNS caching / resolving
                        only.
        --no-local-dns  Do not install local DNS caching / resolving via bind.
        --no-firewall   Do not install ufw and tell ISPConfig to not manage firewall
                        settings on this server.
        --no-roundcube  Do not install roundcube webmail.
        --roundcube     Install Roundcube even when --no-mail is used. Manual
                        configuration of Roundcube config is needed.
        --no-pma        Do not install PHPMyAdmin on this server.
        --no-mailman    Do not install Mailman mailing list manager.
        --no-quota      Disable file system quota
        --no-ntp        Disable NTP setup
        --unattended-upgrades
                        Install UnattendedUpgrades. You can add extra arguments for
                        automatic cleanup and automatic reboots when necessary with
                        --unattended-upgrades=autoclean,reboot (or only one of
                        them).
        --i-know-what-i-am-doing
                        Prevent the autoinstaller to ask for confirmation before
                        continuing to reconfigure the server.
    
    [email protected]:~#
    
    
    
    Then I type yes and hit enter:

    Code:
    [email protected]:~# yes
    
    And this is the result:
    Code:
    y
    y
    y
    y
    y
    y
    y
    y
    y
    y
    y
    y
    y
    y
    y
    y|
     
    Last edited: Mar 19, 2022
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Reading the instructions, the command you used is for
    Reading the instructions further, they state:
    So the command you used is to see what arguments are available. Apply that info to the command you use to autoinstall ISPConfig.
    Note that when you say you typed yes the script did not prompt you for anything. The script had already ended, so the typed yes did not reach the script and resulted in running the command yes. Read
    Code:
    man yes
    to see what that command does (it says "Repeatedly output a line with all specified STRING(s), or 'y'.", which is what happened to you).
     
  5. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    The tutorial says:
    So you can only see all the available arguments if you run that. When you type yes and enter, what you got is already explained by @Taleman above.

    The command that you should run is on the next paragraph and the default will be ISPConfig apache2 perfect server. It says:

    As suggested further you may change the parameter as per the available arguments that you see earlier in order to build other type / specific ISPConfig server.
     
  6. Wotan6891

    Wotan6891 New Member

    hello. Thank you for your answers.

    I have delayed writing because my 2 computers were damaged.

    I had problems installing Debian and I decided on Ubuntu which was very easy as it comes with firmware included.

    install ispconfig 3 this time i did it ok. but when I wanted to open the panel it didn't work in the browser.

    Today I tried again using port 8080 or 8081 but this time the webvirtcloud panel appeared.

    I have done the following:

    1. install a new operating system "ubuntu"
    2. install ispconfig 3

    3. Install qemu/kvm and then create 2 virtual machines. 1 of them is Debian 11
    4. Install webvirtcloud as I saw a tutorial here on this site.
    5. It happens that when I want to open ispconfig, the webvirtcloud panel appears.
    6. I tried to install ispconfig on the Debian virtual machine, but the screen freezes when I open the firefox browser.


    I write all this, to know your recommendation.

    thank you
     
  7. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Sounds like webvirtcloud and ispconfig are probably incompatible, perhaps they use the same ports, or webvirtcloud sets up forwards for them or something. I am very unclear, if not confused, about what you have setup. My only recommendation, aside form the obvious "don't install webvirtcloud and qemu/kvm if it's breaking your setup," would be to try installing ISPConfig using different ports (eg. try 5050/5051 instead of 8080/8081).
     

Share This Page