I have problem with proftpd passvive mode

Discussion in 'General' started by X-admin, Jan 9, 2010.

  1. X-admin

    X-admin New Member

    I want to use proftpd with passive mode, so i add this into /etc/proftpd.conf

    PassivePorts 60000 65000
    and restart proftpd service
    open firewall for these ports

    but when using FTP client to transfer data, it shows:
    227 Entering Passive Mode (203,162,0,214,139,237).
    connecting data channel to
    connection timed out; the connection timed out while waiting for a response from the server.
    PORT 192,168,1,34,65,155
    200 PORT command successful
    150 Opening ASCII mode data connection for file list
    transferred 595 bytes in 0.003 seconds, 1549.479 Kbps ( 193.685 KBps).
    i think my proftpd server doesnot work at passive mode, so i wonder what configuration can i change in ISPConfig else???
    My ISPConfig is 2.2.32

    Many thanks for replies
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Looks like a problem with your firewall. Disable the firewall and try again, if it works then, then you know it is a firewall issue.
  3. X-admin

    X-admin New Member

    Oh, hi Till!

    When enable firewall(iptables), turn off firewall in ISPConfig, i still transfer data to server but i think FTP client use back connect to 20, active mode after didn't detect passive mode

    I disable iptables, and it show:
    227 Entering Passive Mode (203,162,0,214,209,10).
    connecting data channel to
    data channel connected to
    Here, FTP server listen and accept transfer connection at 53514 port while i set passive port from 60000-65000. FTP server should listen like this
    connecting data channel to
    or etc...61000 or 62000.....

    Was i incorrect any where???::(
  4. X-admin

    X-admin New Member

    Oh, who experience this situation?
    I really need some helps!!!

Share This Page