I have problem can't access port 81 on Public IP

Discussion in 'Installation/Configuration' started by nysprite, Jun 8, 2006.

  1. nysprite

    nysprite New Member

    my home network is

    [ADSL Modem]=====eth1(192.168.1.2) Server eth0 (192.168.2.1)=====> PC(Windows)

    When I access from https://192.168.2.1:81/ it's work
    But I try to access from Public router https://xxx.xxx.xxx.xx:81/ it's doesn't work show This page cannot be displayed

    I already NAT port 81 on router and iptables /etc/sysconfig/iptables follow

    :pREROUTING ACCEPT [10:480]
    :pOSTROUTING ACCEPT [1:104]
    :OUTPUT ACCEPT [1:104]
    -A POSTROUTING -o eth1 -j MASQUERADE

    any Idea help me plz.. thank you

    Sprite
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you checked that your provider does not block port 81?

    If you tried to connect from inside your local network to your public IP, this might have been blocked by your router as IP spoofing attempt.
     
  3. shellNewbie

    shellNewbie New Member

    Cannot access IspConfig control panel on port 81

    :) I still cannot seem to access the control panel of ISPConfig from my windows

    output from iptables -L

    [email protected]rvera:/home/lyme# iptables -L
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    output from netstat -tap

    [email protected]:/home/lyme# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN 3949/mysqld
    tcp 0 0 *:www *:* LISTEN 5882/apache2
    tcp 0 0 *:81 *:* LISTEN 4375/ispconfig_http
    tcp 0 0 *:ftp *:* LISTEN 6065/proftpd: (acce
    tcp 0 0 *:smtp *:* LISTEN 5984/master
    tcp 0 0 *:https *:* LISTEN 5882/apache2
    tcp6 0 0 *:imaps *:* LISTEN 4058/couriertcpd
    tcp6 0 0 *:pop3s *:* LISTEN 4098/couriertcpd
    tcp6 0 0 *:pop3 *:* LISTEN 4076/couriertcpd
    tcp6 0 0 *:imap2 *:* LISTEN 4038/couriertcpd
    tcp6 0 0 *:ssh *:* LISTEN 4206/sshd
    tcp6 0 0 *:smtp *:* LISTEN 5984/master
    tcp6 0 444 servera.lymedaisy.c:ssh ::ffff:192.168.200:1521 ESTABLISHED5660/sshd: lyme [pr

    I have edited the hosts file on my pc to include various combinations and get to the parent directory of Ubuntu 7.04 by typing in www.mydomain.com

    by typing /etc/init.d/ispconfig_server start in the bash shell I get this:

    /root/ispconfig/httpd/bin/apachectl startssl: httpd (pid 4375) already running
    FreshClam is already running!
    ISPConfig system is now up and running!

    so I know ISPConfig is there and appears to be working ok.

    Can someone tell me which of the services I need to enable here in my router and what ports to put in .. also if I need to add a particular entry for ISPConfig on port 81.

    sorry if I am being annoying ... just want to at least see the control panel !!:D

    Thank you for your help.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try to connect with another browser, e.g. firefox. Internet Explorer does not provide extensive error messages.

    Please try to connect by IP address to port 81, to make sure that this is not a name resolving problem. esxample:

    http://192.168.0.100:81/
     
  5. shellNewbie

    shellNewbie New Member

    SSL problem

    thanks till for above

    Firefox (on Fedora core 7 this time) tells me that my domain has an invalid SSL cert.

    My question is do I accept defaults for key generation during installation of Ubuntu 7.04 ( I mean the Apache installed as per The perfect setup .... Howto" ) in the same way as outlined for the ISPConfig install here:

    http://www.ispconfig.org/manual_installation.htm

    ?

    To be clear .. do I accept defaults for BOTH Apaches?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

  7. shellNewbie

    shellNewbie New Member

    Postfix Configuration

    Can you please tell me what is the best email address to use during certificate creation for postfix (using the Ububtu 7.04 "Perfect setup - How to")

    where the questionmarks are. :confused:

    Country Name (2 letter code) [AU]:XX
    State or Province Name (full name) [Some-State]:XXXXX-XXXXXXXXX
    Locality Name (eg, city) []:XXXXXXXX
    Organization Name (eg, company) [Internet Widgits Pty Ltd]:XXXXXXXXX XXXX
    Organizational Unit Name (eg, section) []:Home
    Common Name (eg, YOUR name) []:XXXXXXX.XXXXXXXX.com
    Email Address []:?????????????????
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Use one of your own email addresses. In fact, you can use any email address there.
     
  9. shellNewbie

    shellNewbie New Member

    Working fine now

    Finally everything is working really well:

    Ububtu 7.04 server configured as per -
    http://www.howtoforge.com/perfect_setup_ubuntu704

    ISPConfig installed and accessible on my local machine.

    Thanks to falko, till and chuckl for your help.

    :eek:
     
  10. shellNewbie

    shellNewbie New Member

    Working fine now

    Finally everything is working really well:

    Ububtu 7.04 server configured as per -
    http://www.howtoforge.com/perfect_setup_ubuntu704

    ISPConfig installed and accessible on my local machine.

    Thanks to falko, till and chuckl for your help.

    :eek:
     

Share This Page