I get some ERRORS after upgrading to ISPConfig 3.2

Discussion in 'General' started by johnymas, Oct 20, 2020.

  1. johnymas

    johnymas New Member

    I get some ERRORS like
    Backup of web files for domain ..... failed using path /var/www/clients/client2/web6 failed.
    I have approx. 25 web pages but I get errors on four web pages only (sql backups work normally). Other pages creates backup files and sql as before update.
    How to find reason, what is wrong?
     
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Is it a multiserver setup? if yes, do you use mirroring and if so, is this error on the mirror?
    Which backup format is used? Is that format installed on the webserver?
    Do you have any other log entries?
     
  3. johnymas

    johnymas New Member

    It is not a multiserver setup. A you can see from attached image that backup worked normally before upgrade ispconfig into last 3.2 version. I found only cron.log entries that are the same as error inside control panel (see image)
    Where could I find correct log error?
     

    Attached Files:

  4. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    You can debug the backup cron job following these steps:
    Go to System > Server Config -> server1.example.com and set debug level to DEBUG.
    Log in to your server and run
    Code:
    php /usr/local/ispconfig/server/cron_debug.php --cronjob=500-backup.inc.php
    Post the output here.
     
  5. johnymas

    johnymas New Member

    See attached file please..I removed domain names...
     

    Attached Files:

  6. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Please make sure that you select a supported backup method (compression type) and that you have that program installed, too.
     
  7. johnymas

    johnymas New Member

    Of course I have selected supported backup method. I have the same settings for all web sites but I got this error since I have upgraded into 3.2 version but as I said there is a problem on four pages only. Everything worked fine before upgrade. Without any error.
    See settings at attached image.
     

    Attached Files:

  8. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Strange enough.
    Code:
    zip warning: No such device or address
    20.10.2020-12:04 - ERROR - Backup of web files for domain ........... failed using path /var/www/clients/client18/web57 failed.
    
    Readind the warning it seems that zip cannot read the web. May it be that it happens on webs with SSH user (chrooted) enabled?
     
  9. johnymas

    johnymas New Member

    No, there is no SSH user (chrooted) enabled.
     
  10. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Hm, could you deep-check the affected websites if there are any files or folders with special types (device, proc, bind mount etc.) just to try to find the reason why zip is warning about it.
     
  11. clamp2x

    clamp2x New Member

    I also got the same error after updating ispconfig to version 3.2.
    Like johnymas' #3 problem, the ISPConfig log shows that a backup error has occurred, and only the database is backed up in the Backup tab of the domain menu.

    Not all sites are like that, and some sites have problems every day.
    Some of the sites where the problem occurs are those where shell users are created using jailkit.
    Also, some of the sites with problems do not even have a shell user.

    There are a total of about 100 sites on the server, but only 9 sites have backup issues.
    These 9 sites have daily backup errors in the log, and backups are not in progress.
    The 9 sites do not have common settings.
     
  12. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Can you share all related settings for one of the domains with issues?
     
  13. clamp2x

    clamp2x New Member

    Should I show all the tabs in the domain menu?
    What additional settings need to be shared?
     
  14. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Yeah, I am curious if anything is "weird" there. You can leave out the redirect, SSL and stats tab, I don't think one of those settings should be the problem. Make sure to leave out personal details (domain name, passwords, etc)
     
  15. clamp2x

    clamp2x New Member

    Some domain and database file names have been removed.
     

    Attached Files:

  16. clamp2x

    clamp2x New Member

    Another domain on the same server where the same problem occurs.
    The domain above is a domain created with an account with administrative privileges, and the domain in this post is a domain created with general user privileges.

    Both cause the same backup problem.
     

    Attached Files:

  17. johnymas

    johnymas New Member

    Today I got even more errors. I think there must be a bug??
     

    Attached Files:

  18. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Question for both of you: when where these webs created? Can it be that they are the oldest or newest on your system?
     
  19. clamp2x

    clamp2x New Member

    Site creation times vary.
    However, most sites are over a year.
    No site was created after updating ispconfig to version 3.2.
     
  20. johnymas

    johnymas New Member

    Three of the webs were created more than 5 years ago, one of them was created almost a year ago...
    Same as clamp2x said, no site was created after updating to version 3.2.
     

Share This Page