I don't need no stiken FQDNS

Discussion in 'Installation/Configuration' started by braddach, Apr 10, 2008.

  1. braddach

    braddach New Member HowtoForge Supporter

    Well it's me again

    I live out in the sticks, 30 miles from any town, we have 25 houses here and
    no real internet, so I share Hughesnet with 9 houses
    and more to come, we have 5 kids “future page developers” so I'm
    installing ISPConfig for them to practice on using the lan only so
    I don't need FQDNS or any outside DNS at all, so my question is what changes
    do I need to make so the system will accept<dot>net
    I can get from any computer at any house with no problem
    same with shared IP at thats fine cuz I will change that page
    to give instructions on how to access the pages on the system, so again
    how, what and where do I make the necessary changes.

    Thanks for any desperately needed help
  2. HardyHarvey

    HardyHarvey New Member

    I made some changes so that we could test our sites on an internal network. I found that changing the DocumentRoot in /etc/apache2/vhosts/Vhosts_ispconfig.conf from /var/www/sharedip to /var/www enabled me to point to:

    and see the sites.

    There are also changes to make in the file /root/ispconfig/scripts/lib/config.lib.php
    on or about line 1303, where VirtualHost is declared, along with DocumentRoot (remove the trailing /sharedip)

    Hope this helps!
  3. braddach

    braddach New Member HowtoForge Supporter

    Crossed fingers

    SUPER ! and a big THANKS !

    I’ll give that a try as soon as I get home and play WORK on it
    I thunk it was something like that cuz I was thinen about moving the
    page links into the sharedip folder. I’ve installed and reinstalled ETCH
    and ISPConfig no less than 10 times until I made a dump backup, I have
    a pile of notes about a foot high of the things I’ve tried but didn’t mark
    the ones that worked and the ones that failed, soon I hope to add that
    Dolphin social network for them also.

    Again big THANKS !
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Never cahnge the file /etc/apache2/vhosts/Vhosts_ispconfig.conf manually, ISPConfiug will remove all your changes.

    The solution is much easier, just setup domains for every website e.g. site1.tld, site2.tld etc in the ISPConfig dns manager and setup all client computers in your lan to use the dns server on the ispconfig server.
  5. braddach

    braddach New Member HowtoForge Supporter

    Thats the Ticket

    Thanks Till That's the ticket

    I've got a fresh install of ISPConfig, created test client and test.net went to mama's XP added in the dns to the top line opened her browser and in the address bar entered test.net and it worked slick as snot
    boy I'll tell you, then tested howtoforge.com and here I'am, now to change the shared IP index.html to display instructions of how to access local pages.
  6. HardyHarvey

    HardyHarvey New Member

    i also made a custom vhosts and posted to it from apache2.conf but had no working DNS at the time so anyways thanks for setting it straight.. BTW editing the config.lib.php was the re-fix for vhosts manual changes to stick permanently.. but i know you know that.
  7. braddach

    braddach New Member HowtoForge Supporter

    ISPConfig on LAN working just fine and dandy

    I had double posted “sorry” with my DNS problem, in the first post I mentioned that it worked hit and miss un-reliably and even after I placed the in the XP NIC properties "per Till" the browser still took me to the wrong pages then it dawned on me to clear the page history and volla ! it works first time every time.

Share This Page