I could not get the server list from the remote api. Maybe you need to update your ISPConfig first.

Discussion in 'Plugins/Modules/Addons' started by Taleman, Apr 16, 2017.

  1. Taleman

    Taleman Member

    Using dry-run with Migration Tool, version 1.6.5. After answering questions and doing setups as the migration tool commanded, I get an error, see below. I think this spot is pretty close to starting the copying over of settings (if not running dry-run).
    Code:
    Please give me the MySQL root password for 'localhost' on the TARGET WEB/DATABASE (ISPconfig 3) server []: XXXXXXXXXXXXXXXX
    I could not get the server list from the remote api. Maybe you need to update your ISPConfig first.
    ispc3:~/migration# 
    This seems strange. The MySQL password I am pretty sure I typed correctly. The ISPConfig Remote User I believed was already used at the beginning of the migration script, so the remote api works, I think. The TARGET is ISPConfig multiserver setup with version 3.1.2. It has master, a web server and two name servers. It is empty, I am going to populate it with the migration data. SOURCE ISPConfig is version 3.0.5.4p9.

    I'll leave this for today. It took more than an hour to get this far in migration, I'll try again tomorrow. Maybe someone knows what this error is about, so maybe I can avoid it tomorrow.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The error means that the remote server could not be reached, it is no related to MySQL, it is about the remote API connection.

    Posible reasons are:

    - Wrong remote API URL entered.
    - Wrong username or password of the remote user.
    - Not all permissions were granted to the remote user in the target ISPConfig system.
     
  3. Taleman

    Taleman Member

    Thanks, I'll pay attention to those next time running the migration.
    I was unfortunately prevented from working on this yesterday. Problems in computer room, nothing worked until just now.
     
  4. Tomislav Aurednik

    Tomislav Aurednik Member HowtoForge Supporter

    Had the same issue. My problem was I've enterd the private floating IP off my HA cluster. I needed to enter the private IP of the active node and it worked.
     
  5. Taleman

    Taleman Member

    It worked for me the second try. I do not know what I did wrong the first time. I have since run the migrator under script to get a typescript of the session to see what happened.
     
  6. Taleman

    Taleman Member

    I am again doing a migration. This time the same error happened. First time I run the migration tool it gives error "Could not get the server list from the remote api." I just run again the migration tool and second try it works. I did not change the user and password answers.
    Is it possible there is something in the script that causes it to always fail at this point when run for the first time?
     
  7. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Hello,
    it might be that the session expires in the remoting API of the target ISPConfig. All subsequent calls to the API fail afterwards, so the migtool is not able to get any more information. The reason that it works on second try might be that the questions are pre-answered already or answered faster.
     

Share This Page