I can't see my websites in my local network!!!

Discussion in 'Installation/Configuration' started by flyfisherman674, Nov 11, 2007.

  1. flyfisherman674

    flyfisherman674 New Member

    I setup a LAMP server (Ubuntu 6.06LTS) and installed ISPConfig just as it said on "THE PERFECT SETUP". I then added myself as a client under "ADMIN". I then added my 2 websites: www.oregonlifeoutdoors.com and www.cinnamon-bear.com . I checked them through the checkdns.net and it looks as though they are working great and according to checkdns.net they are seeing the (site specific) default index.html that ISPConfig puts in.

    THE PROBLEM IS... I can't see any of this on my local network. I type in www.oregonlifeoutdoors.com or www.cinnamon-bear.com AND all I see is the front page of my router.

    What do I do to make it so I can see these webpages just like the outside world???

    - PatB
  2. wpwood3

    wpwood3 New Member

    Setup a default DMZ server on your router and point it to the local IP address of your Ubuntu server. Look in the WAN settings in your router setup.
  3. flyfisherman674

    flyfisherman674 New Member

    I thinks I got it. I went with PORT FORWARDING over DMZ for security reasons. What I did was update the /etc/host file on the computers (atleast those running Ubuntu Linux) that I was using to access the server and webpages. I added my server and domain as hosts on these computers and NOW I can see the webpages. If you have a better way, please let me know. Still don't know what I need to do for the Windows Vista computer and iMac.

    - Pat B
  4. n1kol1s

    n1kol1s New Member

    You have to do the same thing on vista too. Go to C:\Windows\System32\drivers\etc and edit your host file.
    You have to change the the permisions first to save your changes. Then run ipconfig /flushdns and it should work now.

Share This Page