I can't restart server properly after changing back /etc/network/interfaces

Discussion in 'Installation/Configuration' started by comedit, Aug 17, 2006.

  1. comedit

    comedit New Member

    I have a backup server which by accident i changed the /etc/network/interfaces file to look like:

    (.....first part untouched)
    # the network card
    auto eth0
    iface eth0 inet dhcp
    (I was convinced I was working on another machine : kvm switch are helpfull but deadly as well)

    So with midnight commander i have retyped the whole file according the perfect setup debian (checked it over and over by the letter) and I get this error when I run /etc/init.d/networking restart:

    Setting up IP spoofing protection: rp_filter.
    Reconfiguring network interfaces...ifup: interface lo allready configured
    Don't seem to have all the variables for etho/inet.
    Failed to bring up eth0.

    I can't find anything in the log files which helps me

    does somebody have a clue ?

    thanks in advance
  2. comedit

    comedit New Member

    Found a similar file (from a system image) modified and pasted it: it works now

    Its solved:

    cpoied a file from the machine which was the image of the mainserver.

    It works now so it must have been a typo

    Still didn't figure out what it was but the again it works now


Share This Page