I can't receive emails but send

Discussion in 'Installation/Configuration' started by tom, Apr 9, 2006.

  1. tom

    tom Member

    I can't receive emails. Now I can send mails after adding 127.0.0.1 localhost in /ect/hosts but no mail will reach my from the world.... I feel so lonely :)

    I don't no why - any ideas?

    tom
     
    Last edited: Apr 9, 2006
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please search the mail log for errors. Does the MX record of your domain points correctly to your server domain?
     
  3. tom

    tom Member

    Were I have to look for to see that the MX record points to the right server?

    tom
     
  4. tom

    tom Member

    There is some feeback from postfix:

    But what I've to do?

    tom
     
  5. falko

    falko Super Moderator ISPConfig Developer

  6. falko

    falko Super Moderator ISPConfig Developer

    Run
    Code:
    dig mx yourdomain.com
    to check if the MX record is correct.
     
  7. tom

    tom Member

    I've got that:
    tom
     
  8. sultan_muhd

    sultan_muhd New Member

    i have the same problem i can sen email but cant receive any email
    my domain name is in mx the directory /var/spool/mail contains no mail.
    i got realy headhak
    please help me some one.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post an excerpt of your mail log.

    By the way, please make a new thraed if you have a support question because its likely that you do not have the same problem. Not receiving mails can be caused by 100+ different problems. :)
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Looks ok. :)
     
  11. tom

    tom Member

    I, did a new installation and now I get this in the mail.log:

    and
    and



    any idea?
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    To your first error: Add the line:

    mail.server-domain.top

    at the end of the file /etc/postfix/local-host-names and restart postfix.

    To your sasl error:

    Did you get an error when you restart the sasl auth daemon?
     
  13. tom

    tom Member

    No errors when saslauthd is starting

    I found an bloddy config mistake:
    I've set up the mailbox_size_limit more than message_size_limit and now I'm receivng all the lost mail:)


    What I don't now: Were can I edit message_size_limit?

    tom
     
  14. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ps aux|grep saslauthd
    ?
    Which distribution do you use?

    You can set it in /etc/postfix/main.cf. If it isn't set there, Postfix takes the default values that you can see when you run
    Code:
    postconf -d
     
  15. tom

    tom Member

    I've added message_size_limit = 1024 in /etc/postfix/main.cf restarted postfix and then postconf -d|less but whis no change.
     
  16. falko

    falko Super Moderator ISPConfig Developer

    This sets the message size limit to 1024 bytes... I guess you mean 10240000 (10MB)?


    Code:
    postconf -d
    always shows the default settings. If you want to see your current settings, run
    Code:
    postconf -n
    Did you do the Postfix/saslauthd configuration as described here? http://www.howtoforge.com/perfect_setup_debian_sarge_p4
     
  17. tom

    tom Member

    No, that should be smal for some tests.


    ok

    Exactly I did

    tom
     
  18. sultan_muhd

    sultan_muhd New Member

    ohhh no it is realy confusing me i search a lot of stuff on the net but didnt succied postfix is running well port no 25 is ok but cant recieve mail from outside world. i dont know much about DNS(bind) but when i dig mx it looks like this
    ; <<>> DiG 9.3.1 <<>> mx mydomainname.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 41902
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;mydomainname.com. IN MX

    ;; Query time: 4 msec
    ;; SERVER: 10.0.0.138#53(10.0.0.138)
    ;; WHEN: Wed Apr 12 21:02:33 2006
    ;; MSG SIZE rcvd: 29
    :mad:
     
  19. sultan_muhd

    sultan_muhd New Member

    nop not yet

    ohhh no it is realy confusing me i search a lot of stuff on the net but didnt succied postfix is running well port no 25 is ok but cant recieve mail from outside world. i dont know much about DNS(bind) but when i dig mx it looks like this
    ; <<>> DiG 9.3.1 <<>> mx mydomainname.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 41902
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;mydomainname.com. IN MX

    ;; Query time: 4 msec
    ;; SERVER: 10.0.0.138#53(10.0.0.138)
    ;; WHEN: Wed Apr 12 21:02:33 2006
    ;; MSG SIZE rcvd: 29
    :mad:
     
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    PLease ask your ISP if they block port 25. Many ISP do that!
     

Share This Page