I can't receive email.

Discussion in 'Installation/Configuration' started by tomaszm, Aug 30, 2011.

  1. tomaszm

    tomaszm New Member


    I've centos 5.6 server with ispconfig 3. I don't see any email in webmail, but I've emails in /var/vmail/example.com/test/new also I can send emails. This is my main.cf
    My master.cf
    Logs from maillog
    I've mx records in dns. I get main.cf and master.cf config from my old server (debian with ispconfig 3, on this server emails works.).

    P.S sorry for my english.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    According to the mail.log and your description that the mails are in /var/vmail/example.com/test/new folder, mail delivery works fine. Please ensure that you logged in with the correct username to the webmail client, the username is the full email address. If you are laready logged in, press on the refresh link in the webmail client and ensure that you are viewing the inbox folder.
  3. tomaszm

    tomaszm New Member

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    netstat -tap | grep imap
  5. tomaszm

    tomaszm New Member

    [[email protected] /]# netstat -tap | grep imap
  6. falko

    falko Super Moderator ISPConfig Developer

    Do you use SquirrelMail? Did you configure SquirrelMail in the beginning and tell it that you use Dovecot?
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    According to your config files, your server is configured to use courier as pop3 / imap server. But currently dovecot is started and not courier. Dovecot and courier use a different setup and directory structure for the mailboxes.

    Please stop and disable dovecot and then start couriert pop3, imap and authdaemon.

    Which tutorial did you use to install your server?
    Last edited: Aug 31, 2011
  8. tomaszm

    tomaszm New Member

    I install and configure courier. I've emails in my box but now I can't send emails.

    I used this tutorial: http://www.howtoforge.com/perfect-server-centos-5.6-x86_64-ispconfig-3

    But I moved server based on this tutorial: http://www.howtoforge.com/perfect-server-debian-lenny-ispconfig3-p4

    OK i fix that.
    Just use /usr/sbin/postfix set-permissions
    Last edited: Aug 31, 2011
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    What have you changed in postfix config files? The delivery was working fine before, so there must have been changes in the main.cf or master.cf file.

    By the way, it would have been better if you stayed with debian. Its much more stable and causes less problems. For example the problems in this thread could not have happed with debian as it detects when ypu try to install a duplicate pop3 / imap server.
  10. tomaszm

    tomaszm New Member

    I don't change anything, file premissions was wron.

    I want to use thunderbird to get and send emails, but I can't connect to smtp sever. Do you know how to configure thunderbird or smtp to send emails?
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    There is a bug in thunderbird that removes the part after the @ in usernames (only in smtp and not in pop3 / imap). To fix that, go to smtp settings in thunderbird and edit the account and enter the full email address as username and not just the part before the @ sign.
  12. tomaszm

    tomaszm New Member

    I know this but, when i set smtp server to mydomain.com and port 25, without encryption and password just a text. I can't connect to the server. I mean when I want to send email I get timeout error.


Share This Page