I can't receive a specific email: NOQUEUE: reject: RCPT Helo command rejected: Host not found

Discussion in 'Server Operation' started by Milly, Sep 4, 2020.

  1. Milly

    Milly Member


    Mail from a university, for example [email protected] does not reach my server's mailbox, but gmail does.

    The server works fine, I receive emails from other sites and everything is normal.

    I have the following message in the mail.log:

    • If I enter mail.university.ar.ra if a website is displayed in the browser
    • If I enter mail.domainuniversity.com a website is not displayed in the browser

    So it is possible that the mail.domainuniversity.com is not configured correctly, that's why my server does not receive it, but gmail does.

    What I have tried for tests according to the manual and it does not work:

    • Add the email address and the two websites to the postfix whitelist in global filters and ispconfig spam filter
    • In Domain and Mailbox I select the spam filter: Unsensored.

    The questions are:

    1. How can I get emails from this site?
    2. How could I allow emails from sites with the .ar.ra domain that are from universities and the government?

    Sorry for the questions and thank you very much for the help.
  2. Steini86

    Steini86 Active Member

    You probably have an "reject_unknown_helo_hostname" in your /etc/postfix/main.cf If you remove this item, the mail should go through (reload postfix after the change).
    You can also try to put domain .ar.ra to the postfix whitelist (not sure, if that works, though)

    There are two reasons for this error:
    1) The sending server is badly configured
    2) The DNS resolver of your server is faulty (can also be a timeout, etc..)
    Milly likes this.
  3. Milly

    Milly Member

    As you have indicated, I have deleted


    From the line:

    smtpd_helo_restrictions = permit_sasl_authenticated, permit_mynetworks, check_helo_access regexp:/etc/postfix/helo_access, reject_invalid_hostname, reject_non_fqdn_hostname, reject_invalid_helo_hostname, reject_unknown_helo_hostname, check_helo_access regexp:/etc/postfix/blacklist_helo

    And it has worked, I'm going to keep it this way while I find another solution.

    And do you know how I can exclude all domains for example .ar.ra (they are from the government and universities) from the restrictions of "smtpd_helo_restrictions"?

    About postfix whitelist the truth does not work for this email.

    Thank you very much[/SPOILER]
  4. Steini86

    Steini86 Active Member

    The helo restrictions are being evaluated from beginning to end. So first "sasl_authentificated clients" and "your networks" are allowed, then the file /etc/postfix/helo_access is evaluated. Then all the rejects are done. So if you allow the hosts in "/etc/postfix/helo_access" with a regular expression you should be good. This can be done with a line like
    /^.*=.ar.ra$/ OK
    (untested! You can test your regular expressions with "postmap -q": http://www.postfix.org/regexp_table.5.html)
    Milly likes this.
  5. Milly

    Milly Member

    Thank you very much for the help Steini86, I will do the tests


Share This Page