I can't login

Discussion in 'Installation/Configuration' started by brian, Aug 26, 2006.

  1. brian

    brian New Member

    I just installed ispconfig 2.2.6. Everything appeared to install ok. I didn't get any errors anyway. At the end of the install it said to login using the username admin and password admin. When I try to login, I get a wrong username or password error message. Is this the correct login info for this version of ispconfig? If so, is there a way to get around this problem so that I can login?
  2. brian

    brian New Member

    bumping thread

    Does anyone have an answer for this problem? Any help will be greatly appreciated.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you create the database for ISPConfig manually before you installed ISPConfig or did your mysql user had no root priveliges? Did you run the ISPConfig setup several times?
  4. brian

    brian New Member

    Thanks For Answering Till

    Thanks for the reply till. Yes I did create a database for ispconfig and assigned it to a user with root privs along with full privs to the database. After running the install three times I have found that ispconfig setup is not poulating the database with any tables at all.

    I had ispconfig 2.2.0 on my other server and had no problem getting it up and running. I replaced my servers hardware and decided to go with 2.2.6 instead. From what I can see there is no difference in the setup from 2.2.0 to 2.2.6. I even went as far as to install 2.2.0 on the new server and got the same thing (no tables). Any ideas?

    Thanks again for replying.

  5. falko

    falko Super Moderator ISPConfig Developer

    You must not create the ISPConfig database manually! This must be done by the installer. Please delete your empty ISPConfig database, don't create a new one, and run the installer again. When you're asked for the MySQL user, enter root.
  6. brian

    brian New Member

    Thanks Falko

    That was the problem. For some reason I thought that I had to create the database manually before installing. I guess that I had the ispconfig install confused with another installation.

    Thanks again. I really appreciate the help.


Share This Page