I can't generate Let's Encrypt certificates anymore

Discussion in 'Installation/Configuration' started by Joueur Citoyen, Dec 3, 2020.

  1. Joueur Citoyen

    Joueur Citoyen New Member

    Hello people at HowtoForge. I'm very sorry for asking but I've been stuck with this one for a long time.

    I run a webserver with ISPConfig 3.1.11 and it's online since march 2018. I installed multiple websites on it and I used to create Let's Encrypt certificates by checking the SSL + Let's Encrypt checkboxes. It was easy! It still worked in november 2019. But recently, I cannot do it anymore. It has been a little time since when I cannot check the boxes anymore. When I check SSL + Let's Encrypt, nothing happens. The websites that are already on air still have their certificate working, but I can't create one for new websites.

    Do you have a clue about why? By the way, I never updated the server, I only installed newer versions of PHP some months ago. Maybe it's related but I'm not sure at all. It's really peanlizing since I can't create new website in https anymore. Do someone has a clue about this one?

    Thanks for reading!
    Cheers, Julien
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    ^ and I would advice you to keep your system up to date - both ISPConfig and your other software.
    ahrasis likes this.
  4. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    I remember certbot webroot issue was fixed on 3.1.13 or so, as such I couldn't agree more with what @Th0m said.

Share This Page