I can´t conect to ftp if i use a client ftp

Discussion in 'Installation/Configuration' started by chua_jose, Dec 2, 2007.

  1. chua_jose

    chua_jose New Member

    Hi,
    i have ispconfig installed in my server. When i try to conecto to ftp with ftp client (example: filezilla), i can´t conect.
    If, i contect to ftp by ftpweb, i haven´t any problem, but when i use Filezilla, and write ftp.xxxxx.com, i can´t conect. If i write xxxx.com, the conection is ok, but i can´t loggin because user or pass it´s wrong.
    this is my config files:
    File proftp_ispconfig.cof
    [root@xxxxxxxxxxxxxxetc]# vi proftpd_ispconfig.conf
    ###################################
    #
    # ISPConfig proftpd Configuration File
    # Version 1.0
    #
    ###################################
    #DefaultAddress 127.0.0.1
    <VirtualHost 192.168.0.253>
    DefaultRoot ~
    AllowOverwrite on
    Umask 002
    </virtualhost>
    <VirtualHost 91.34.68.83>
    DefaultRoot ~
    AllowOverwrite on
    Umask 002
    </virtualhost>


    And this file is proftpd.conf

    [root@xxxxxxxxxxxxxxetc]# vi /etc/proftpd.conf
    ServerName "ProFTPD server"
    ServerIdent on "FTP Server ready."
    ServerAdmin root@localhost
    ServerType standalone
    #ServerType inetd
    DefaultServer on
    AccessGrantMsg "User %u logged in."
    #DisplayConnect /etc/ftpissue
    #DisplayLogin /etc/ftpmotd
    #DisplayGoAway /etc/ftpgoaway
    DeferWelcome off

    # Use this to excude users from the chroot
    DefaultRoot ~ !adm

    # Use pam to authenticate (default) and be authoritative
    AuthPAMConfig proftpd
    AuthOrder mod_auth_pam.c* mod_auth_unix.c

    # Do not perform ident nor DNS lookups (hangs when the port is filtered)
    IdentLookups off
    UseReverseDNS off

    # Port 21 is the standard FTP port.
    Port 21

    # Umask 022 is a good standard umask to prevent new dirs and files
    # from being group and world writable.
    Umask 022

    # Default to show dot files in directory listings
    ListOptions "-a"

    # See Configuration.html for these (here are the default values)
    #MultilineRFC2228 off
    #RootLogin off
    #LoginPasswordPrompt on
    #MaxLoginAttempts 3
    #MaxClientsPerHost none
    #AllowForeignAddress off # For FXP

    # Allow to resume not only the downloads but the uploads too
    AllowRetrieveRestart on
    AllowStoreRestart on

    # To prevent DoS attacks, set the maximum number of child processes
    # to 30. If you need to allow more than 30 concurrent connections
    # at once, simply increase this value. Note that this ONLY works
    # in standalone mode, in inetd mode you should use an inetd server
    # that allows you to limit maximum number of processes per service
    # (such as xinetd)
    MaxInstances 20

    # Set the user and group that the server normally runs at.
    User nobody
    Group nobody

    # Disable sendfile by default since it breaks displaying the download speeds in
    # ftptop and ftpwho
    UseSendfile no

    # This is where we want to put the pid file
    ScoreboardFile /var/run/proftpd.score

    # Normally, we want users to do a few things.

    AllowOverwrite yes

    AllowAll

    # Define the log formats
    LogFormat default "%h %l %u %t \"%r\" %s %b"
    LogFormat auth "%v [%P] %h %t \"%r\" %s"
    # TLS
    # Explained at http://www.castaglia.org/proftpd/modules/mod_tls.html
    #TLSEngine on
    #TLSRequired on
    #TLSRSACertificateFile /etc/pki/tls/certs/proftpd.pem
    #TLSRSACertificateKeyFile /etc/pki/tls/certs/proftpd.pem
    #TLSCipherSuite ALL:!ADH:!DES
    #TLSOptions NoCertRequest
    #TLSVerifyClient off
    ##TLSRenegotiate ctrl 3600 data 512000 required off timeout 300
    #TLSLog /var/log/proftpd/tls.log

    # SQL authentication Dynamic Shared Object (DSO) loading
    # See README.DSO and howto/DSO.html for more details.
    #
    # LoadModule mod_sql.c
    # LoadModule mod_sql_mysql.c
    # LoadModule mod_sql_postgres.c
    #

    # A basic anonymous configuration, with an upload directory.
    #
    # User ftp
    # Group ftp
    # AccessGrantMsg "Anonymous login ok, restrictions apply."
    #
    # # We want clients to be able to login with "anonymous" as well as "ftp"
    # UserAlias anonymous ftp
    #
    # # Limit the maximum number of anonymous logins
    # MaxClients 10 "Sorry, max %m users -- try again later"
    #
    # # Put the user into /pub right after login
    # #DefaultChdir /pub
    #
    # # We want 'welcome.msg' displayed at login, '.message' displayed in
    # # each newly chdired directory and tell users to read README* files.
    # DisplayLogin /welcome.msg
    # DisplayFirstChdir .message
    # DisplayReadme README*
    # # Some more cosmetic and not vital stuff
    # DirFakeUser on ftp
    # DirFakeGroup on ftp
    #
    # # Limit WRITE everywhere in the anonymous chroot
    #
    # DenyAll
    #
    #
    # # An upload directory that allows storing files but not retrieving
    # # or creating directories.
    #
    # AllowOverwrite no
    #
    # DenyAll
    #
    #
    #
    # AllowAll
    #
    #
    #
    # # Don't write anonymous accesses to the system wtmp file (good idea!)
    # WtmpLog off
    #
    # # Logging for the anonymous transfers
    # ExtendedLog /var/log/proftpd/access.log WRITE,READ default
    # ExtendedLog /var/log/proftpd/auth.log AUTH auth
    #
    #

    DefaultRoot ~

    Include /etc/proftpd_ispconfig.conf

    thanks
     
    Last edited: Mar 8, 2008
  2. till

    till Super Moderator

    First, if you want to use a subdomain like ftp.xxxxx.com, you must set this up in the authoritive DNS server for this domain.

    If you are able to connect with WebFTP, then FTP is working fine on the server. Just use the exact same username and password in your external FTP client.
     
  3. chua_jose

    chua_jose New Member

    I deleted this part on proftpd_ispconfig:
    <VirtualHost 192.168.0.253>
    DefaultRoot ~
    AllowOverwrite on
    Umask 002
    </virtualhost>

    And all OK
    thanks
     
  4. chua_jose

    chua_jose New Member

    i continue with that problem.
    if i write ftp.xxxx.com i can´t conect but if i write xxxxx.com i can perfect conection.

    if i erase this part on proftpd_ispconfig
    <VirtualHost 192.168.0.253>
    DefaultRoot ~
    AllowOverwrite on
    Umask 002
    </virtualhost>

    All ok, but when i create the new one client or Cname or A Record, the file proftp_ispconfig.conf returns to his previous condition. With which it does not work. If I return to erase , it returns to work.

    Thaks for all and pardon for my english
     
  5. edge

    edge HowtoForge Supporter

    Like till said.

    You WILL need to create an A record "ftp" pointing to the IP of xxxx.com
    Do not mess with the "proftpd_ispconfig" file. It will get overwritten as soon as you make a change in ISPconfig.
     
    Last edited: Dec 3, 2007
  6. chua_jose

    chua_jose New Member

    I go to DNS-manager and select my site. I create in an A record "ftp" pointing to the IP public, but i can´t conect.
    This message:
    Status: Connecting to ftp.airfreenavarra.com ...
    Error: Unable to connect!

    If i don´t delete this part on proftpd_ispconfig:

    <VirtualHost 192.168.0.253>
    DefaultRoot ~
    AllowOverwrite on
    Umask 002
    </virtualhost>

    I recibed this message:

    Status: Connecting to airfreenavarra.com ...
    Status: Connected with airfreenavarra.com. Waiting for welcome message...
    Response: 220 ProFTPD 1.3.1 Server (ProFTPD server) [::ffff:192.168.0.253]
    Command: USER airfreenavarra.com_ftp
    Response: 331 Password required for airfreenavarra.com_ftp
    Command: PASS **********
    Response: 530 Login incorrect.
    Error: Unable to connect!


    Thanks
     
  7. till

    till Super Moderator

    Please read my post above:

    The dns manager is not nescessarily the authoritive DNS server. Plaese go into the domain control panel of your registry and check if the dns server of the registry or your own server is authoritive for the domain. If the dns server of the registry is authoritive, which I guess, then you will have to create the DNS A-Record there and not in ISPConfig.
     
  8. edge

    edge HowtoForge Supporter

    One more thing.
    If you want people from outside your network (the rest of the world) to be able to access your site, you will need to use your WAN (real) IP, and not the LAN IP.

    At the moment when I ping your domainname from here I get a LAN IP back. (192.168.0.253)

    Again this is no problem if you only want to use the domain on your LAN, but people from outside it will not be able to access it.

    When I ping ftp.yourdomain.com I do get the (I think) correct IP back.
    Going with my browser to http://ftp.yourdomain.com, I do also get an ISPconfig page.

    Make sure when you try to login with FTP that you use webNR_name (the ISPconfig User name), and NOT the email address! as login name!
     
    Last edited: Dec 3, 2007

Share This Page