I cannot resolve www.example.com on the local machine

Discussion in 'Installation/Configuration' started by braakiss, Jan 9, 2007.

  1. braakiss

    braakiss New Member

    Hi everyone,
    Mi problem is that I cannot resolve www.example.com in my local machine where I have installed ispconfig ( It is a vmware virtual machine )

    I have a domain and a subdomain:


    When I put in firefox ( in the virtual machine where I have ispconfig ) either www.example.com or sub1.example.com it shows "Test for the Apache web server" instead of "welcome to www.example.com" or "welcome to sub1.example.com". If I do that in another machine it works properly, it shows "welcome to..."

    What is the problem?

    Thanks in advance

    Fernando M.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check with e.g. ping that the domain resolves to the same IP on both machines.
  3. braakiss

    braakiss New Member

    Hi Till,
    If I do "ping www.example.com" on both machines it resolves, the same IP.

    any idea?
    Last edited: Jan 9, 2007
  4. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/hosts? What's the output of
    ? What's in Vhosts_ispconfig.conf?
  5. braakiss

    braakiss New Member

    hi Falko,


    ifconfig output:


    thanks again
  6. falko

    falko Super Moderator ISPConfig Developer

    Can you change

    ::1 sub1.example.com sub1 www.example.com www localhost.localdomain localhost
    ::1 localhost.localdomain localhost
    in /etc/hosts?

Share This Page