I cannot Access The config page no more

Discussion in 'Installation/Configuration' started by 0plus1, Oct 7, 2008.

  1. 0plus1

    0plus1 New Member

    hi to everybody, I'm trying that wonderful software called ISPCONFIG, i setted up a site (using an external DNS not having more than one public ip to try) that still works, the problem is that i cannot access the control panel! Other than leaving the server on for a couple of weeks without thouching it i didn' t do anything, now, all of a sudden i get:

    ssl_error_rx_record_too_long on the https page
    and unreachable site on both the ssl and normal :81 page

    I tried to update isp config to 2.2.26 and regenerate the ssl certificate (not needing one official i generated one myself) but no luck.

    Can you guys give me some advice?

    Thank you so much
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. 0plus1

    0plus1 New Member

    The link point to your profile..

    Recreating the certificate didn't work, i actually uninstalled everything then installed again.. now it seems to work

    thanks
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. lusso64

    lusso64 New Member HowtoForge Supporter

    I have exactly the same issue after upgrading to .28

    I have tried regenerating the SSL Cert but still get (Error code: ssl_error_rx_record_too_long)

    When performing the upgrade, which of my conf files would have been overwritten? Maybe that's where I need to be looking?

    Other sites on the box are working fine - just no admin. I also use port 82, not 81, but this was working previously - hence my question about overwritten conf files.

    Thanks in Advance...
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Everything in /root/ispconfig and /home/admispconfig gets overwtitten.

    Then do it again as described in the thread above. As the error states, you entered a value thatw as too long.
     
  7. lusso64

    lusso64 New Member HowtoForge Supporter

    Okay. I redid the cert, restarted ispconfig, and same error. I used all the default values for the SSL Cert creation - e.g. AU, Widgets etc.

    It must be something simple that I have messed up in a config file....

    EDIT - appears that email is not working for any domain on the box also.
     
  8. lusso64

    lusso64 New Member HowtoForge Supporter

    Ok. All fixed. The upgrade overwrote the config files. The problems were multiple but all related to httpd.conf

    I thought I backed these up, but as it turns out I only backed up the "main" config files, not the ones dedicated to the ispconfig apache server.

    O well, live and learn...
     

Share This Page