I can not access to the ISPconfig first page

Discussion in 'Tips/Tricks/Mods' started by freesqrt, Jan 5, 2010.

  1. freesqrt

    freesqrt New Member

    Hi there,

    I have gotten a bad headache after the recently installing of ISPconfig2.
    After of the forst installing, I access to panel by https. but after a few hours up to now I just receive "network timeout" and can not access to the first page of it.
    I reinstall it several times but...
    nmap shows that port 81 in open but I can not telnet to 81 from outsite. in addition netstat shows that ispconfig in listening to port 81!!!
    finally, I can login by lynx on the server itself but not from anywhere else!!!

    can anyone tell me what happens?

    Regards,
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Can you post the outputs of
    Code:
    netstat -tap
    and
    Code:
    iptables -L
    ?
    Which distribution do you use?
     
  3. freesqrt

    freesqrt New Member

    Hi Falko,

    thank you for attention,

    output of "netstat -tap" is:

    ---------------------------------
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN 6410/mysqld
    tcp 0 0 *:www *:* LISTEN 21272/apache2
    tcp 0 0 *:webmin *:* LISTEN 5432/perl
    tcp 0 0 *:81 *:* LISTEN 21194/ispconfig_htt
    tcp 0 0 mx1.tpnu.ac.ir:domain *:* LISTEN 21421/named
    tcp 0 0 localhost.locald:domain *:* LISTEN 21421/named
    tcp 0 0 localhost.localdoma:953 *:* LISTEN 21421/named
    tcp 0 0 *:smtp *:* LISTEN 21370/master
    tcp 0 0 *:https *:* LISTEN 21272/apache2
    tcp6 0 0 [::]:imaps [::]:* LISTEN 4913/couriertcpd
    tcp6 0 0 [::]: pop3s [::]:* LISTEN 4947/couriertcpd
    tcp6 0 0 [::]: pop3 [::]:* LISTEN 4927/couriertcpd
    tcp6 0 0 [::]:imap2 [::]:* LISTEN 4893/couriertcpd
    tcp6 0 0 [::]:ftp [::]:* LISTEN 21463/proftpd: ( acc
    tcp6 0 0 [::]:ssh [::]:* LISTEN 28081/sshd
    tcp6 0 0 ip6-localhost:953 [::]:* LISTEN 21421/named
    tcp6 0 0 [::]:smtp [::]:* LISTEN 21370/master
    tcp6 0 1632 mx1.tpnu.ac.ir:ssh 94-182-132-93.ras:25604 ESTABLISHED 22093/sshd: tpnu [p
    ----------------------------------------

    and "iptables -L" is:

    -----------------------------
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination
    ------------------------------

    I stop the bastille-firewall service.
    I use Ubuntu 8.04TLS, kernel 2.6.24-16

    when I nmap from outside :

    ---------------------
    PORT STATE SERVICE
    21/tcp open ftp
    22/tcp open ssh
    25/tcp open smtp
    53/tcp open domain
    80/tcp open http
    110/tcp open pop3
    143/tcp open imap
    443/tcp open https
    993/tcp open imaps
    995/tcp open pop3s
    3306/tcp open mysql
    10000/tcp open snet-sensor-mgmt
    -------------------

    Thank you very very much,
     
    Last edited: Jan 6, 2010
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Is the server in your local network? If so, did you try to access it from within your local network or from outside? If from outside, did you configure your router to forward port 81 to your ISPConfig server?
     
  5. freesqrt

    freesqrt New Member

    Yes, I think it is the point!!
    the router ACL prevent port 81. Is there any way to change port 81 in ISPconfig to 8080 ?
    because I had not any problem with ISPconfig 3 that serve us on 8080.

    Regards,
     
    Last edited: Jan 9, 2010
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You must change the port in /root/ispconfig/httpd/conf/httpd.conf and /home/admispconfig/ispconfig/lib/config.inc.php. Restart ISPConfig afterwards.
     
  7. freesqrt

    freesqrt New Member

    Thank you very much

    It was officially hard for me to open port 81 on gateway but i changed it to 8080 and everything is O.K now.

    thank you again Falko,
     

Share This Page