I can no longer access ispconfig after Certbot installation

Discussion in 'Server Operation' started by mymmo73, Nov 7, 2019.

  1. mymmo73

    mymmo73 New Member

    Hi everyone, I have a problem, I state that I don’t understand anything about linux, following a video I installed a web server with ubuntu version 18.04.2 with cpu Intel Xeon Processor 2GHz then I installed ispconfig to manage sites, until yesterday afternoon is everything went well, last night I realized that by connecting to the sites they all returned the following error “Error establishing a database connection” the same error me since I try to access the ispconfig panel, something I did two days ago was to install cerbot to get ssl certificates for my sites … from this page https://certbot.eff.org/lets-encrypt/ubuntubionic-apache.
    I have access to the shell.

    My domain is: tradingforum.it

    I ran this command: I ran all the commands in this guide https://certbot.eff.org/lets-encrypt/ubuntubionic-apache

    It produced this output:

    My web server is (include version):ubuntu 18.04.2

    The operating system my web server runs on is (include version):ubuntu 18.04.2

    My hosting provider, if applicable, is: tophost.it/

    I can login to a root shell on my machine (yes or no, or I don’t know):yes

    I’m using a control panel to manage my site (no, or provide the name and version of the control panel): I use ispconfig 3 the precise version I don’t remember

    The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): Cerbot 0.31.0
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    You should post on ISPConfig forum for ISPConfig problems.
    Do this first:
    https://www.howtoforge.com/community/threads/please-read-before-posting.58408/
    My guess is certbot has messed apache configuration, if you can not connect to ISPConfig panel. Or maybe database is not running? Try
    Code:
    # systemctl --state=failed
    # apachectl configtest
    If you can not get it working, install again but not from video, use the ISPConfig Perfect Server Guide: https://www.howtoforge.com/tutorial...l-pureftpd-bind-postfix-doveot-and-ispconfig/
    If you follow that guide, you get Let's Encrypt certificates for your websites by turning on the Let's Encrypt box on website settings.
     
  3. mymmo73

    mymmo73 New Member

    thanks for your availability I have executed the commands that you suggested to me:
    Code:
    [email protected]:~# systemctl --state=failed
      UNIT                  LOAD   ACTIVE SUB    DESCRIPTION
    ● clamav-daemon.service loaded failed failed Clam AntiVirus userspace daemon
    ● fail2ban.service      loaded failed failed Fail2Ban Service
    ● mysql.service         loaded failed failed MySQL Community Server
    ● quotaon.service       loaded failed failed Enable File System Quotas
    
    LOAD   = Reflects whether the unit definition was properly loaded.
    ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
    SUB    = The low-level unit activation state, values depend on unit type.
    
    4 loaded units listed. Pass --all to see loaded but inactive units, too.
    To show all installed unit files use 'systemctl list-unit-files'.
    [email protected]:~# apachectl configtest
    AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.conf:73
    Syntax OK
    [email protected]:~# 
     
  4. Steini86

    Steini86 Active Member

  5. mymmo73

    mymmo73 New Member

    thank you very much for your suggestions I solved everything with this simple command:
    Code:
    # service mysql restart
     

Share This Page