I broke my PHP

Discussion in 'Server Operation' started by paulororke, Apr 5, 2008.

  1. paulororke

    paulororke New Member

    I can't seem to find an answer to this problem, if it's in another post that I missed I apologize.

    Recently I upgraded a few apache packages on mt Debial Sarge LAMP server as per this document: http://plone.org/documentation/tuto...-using-repoze/setting-up-a-clean-linux-server My intention was to install Plone behind my existing Apache2 installation. Unfortunately when doing the apt-get install apache2 part php5 was removed. I had expected to simply get a message that apache2 was already installed but it made quite a few changes.

    To cut to the chase, I can't load the php5 module:

    Code:
    lamp:~# a2enmod php5
    This module is already enabled!
    Code:
    lamp:~# /etc/init.d/apache2 force-reload
    Forcing reload of web server: Apache2 ... failed!
    You may still have some apache2 processes running.  There are
    processes named 'apache2' which do not match your pid file,
    and in the name of safety, we've left them alone.  Please review
    the situation by hand.
    Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load:
    Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/apache2/modules/libphp5.so: cannot open shared object file: No such file or directory
    so it seems the .so (shared object?) file was indeed removed but when I try to use apt-get to install php5:
    Code:
    lamp:~# apt-get install php5
    Reading Package Lists... Done
    Building Dependency Tree... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    
    Since you only requested a single operation it is extremely likely that
    the package is simply not installable and a bug report against
    that package should be filed.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
      php5: Depends: libapache2-mod-php5 (>= 5.2.5-0.dotdeb.2) but it is not going to be installed or
                     libapache-mod-php5 (>= 5.2.5-0.dotdeb.2) but it is not going to be installed or
                     php5-cgi (>= 5.2.5-0.dotdeb.2) but it is not going to be installed
    E: Broken packages
    
    
    Code:
    lamp:~# apt-get install libapache2-mod-php5
    Reading Package Lists... Done
    Building Dependency Tree... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    
    Since you only requested a single operation it is extremely likely that
    the package is simply not installable and a bug report against
    that package should be filed.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
      libapache2-mod-php5: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge4.xs3.2.0.58 is to be installed
                           Depends: libkrb53 (>= 1.4.2) but 1.3.6-2sarge5 is to be installed
                           Depends: libssl0.9.8 (>= 0.9.8c-1) but it is not installable
                           Depends: libxml2 (>= 2.6.27) but 2.6.16-7 is to be installed
    E: Broken packages
    
    I've tried apt-get update and apt-get upgrade but I don't seem to ba able to resolve these dependencies.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/apt/sources.list?
     
  3. paulororke

    paulororke New Member

    sources.list

    Code:
    [email protected]:~$ cat /etc/apt/sources.list
    deb http://ftp.debian.org/debian sarge main
    deb http://www.backports.org/debian/ sarge-backports main
    deb http://dotdeb.pimpmylinux.org/ stable all
    deb-src http://ftp.debian.org/debian sarge main
    deb-src http://www.backports.org/debian/ sarge-backports main
    deb-src http://dotdeb.pimpmylinux.org/ stable all
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Please replace all references to stable with sarge because now Etch is stable, and Sarge is oldstable.
     
  5. paulororke

    paulororke New Member

    Thanks - that worked.

    I still had a version conflict with dotdeb. I needed 5.2.5-0.dotdeb.0 - I had 5.2.5-0.dotdeb.2 but removing and reinstalling with apt-get put in the right version, from there everything went in place as expected.

    Now I'm finding php errors I didn't have - due to changes in php5 I suspect (I wrote much of my stuff for php4) - but that's another issue.

    Thanks again for the help - most appreciated. :)
     

Share This Page