I am having difficulty getting mailserver to work as expected.

Discussion in 'Installation/Configuration' started by westlc01, Jun 6, 2007.

  1. westlc01

    westlc01 New Member

    Hi everyone, firstly can I point out that this is a steep learning curve for me.

    I have set up a sandpit, consisting of 2 PC's an ADSL router, a fixed IP and a Domain.

    Lets say the PCs are called Workstation1 and Server1, having internal IP addresses of 192.168.1.1 and 192.168.1.2 The domain is test.com and the fixed IP is 99.99.99.99

    The router has port forwarded ports 110 and 25 to 192.168.1.2 and opened up holes in the router firewall for ports 110 & 25 by allowing TCP packets to these ports.

    Server1 has ubuntu 6.10 (perfect setup) and ISPCONFIG installed.

    In ISPCONFIG I have created a new client and site called test.com with a user 'user01' created with an email address of '[email protected]' and password 'xxx'.

    To complete the picture I have created DNS entries at zoneedit.com for test.com pointing both test.com and 'www.test.com' to 99.99.99.99. I have also created an MX record at zoneedit.com for mail.test.com to be handled by test.com

    I hope so far I have done the right thing.

    Workstation1 is a windows XP box with outlook installed.

    Now the problem.... :rolleyes:

    When I create an email account in outlook for '[email protected]' using the user01 credentials and SMPT and pop3 settings as mail.test.com and then test the account settings, it cant find the pop3 or the SMPT server.

    If I change the POP3 and SMPT server to test.com it finds both the SMPT and POP3 servers, logs onto the POP3 server but fails at sending a test email. Additionally if I send an email from worstation as '[email protected]' to itself then it sends and recieves the email OK. But if I send the email from another email account on the internet I do not recieve it. If I send from '[email protected]' to someone on the internet they recieve it.

    Can someone please help me here or point me in the right direction.

    Thankyou

    Craig
     
  2. Hans

    Hans Moderator ISPConfig Developer

    Did you register a domain name and does the A-record and MX-10 record of that domain name point to your external IP-address 99.99.99.99?

    Try to establish a Telnet session from outside your LAN to your external IP-address or your servers’ full qualified domain name, like this:

    telnet 99.99.99.99 25 or telnet www.yourdomain.tld 25
     
  3. edge

    edge Active Member Moderator

    I think that Hans meant to say: "does the MX-10 record of that domain name point to your A record." (A MX record should not point directly to an IP)
     
  4. Hans

    Hans Moderator ISPConfig Developer

    Thanks Edge, that's correct. :)
     
  5. westlc01

    westlc01 New Member

    Thanks Hans,

    thats narrowed it down a bit. I could not establish a conection on port 25. So I tried port 110 and could make a conection, both by IP and FQDN.

    Next I turned of all firewalling on the rounter and set up a DMZ to 192.168.1.2 (SERVER2). This should forward all traffic through to that server, from my limited knowledge.. Tried again but same results ie can connect to 110 but not 25. This sugests its a SMPT problem on the server doesn't it? (by the way I checked with my ISP and they do not block port 25).

    The question is, is it the way I have ubuntu set up, the mail server or ISPCONFIG or something else...

    I'm starting to need a piece of hose to breath through I am getting so far out of my depth and comfort zone :eek: But thats how you learn I guess.

    Where should I look next? Cheers people
     
  6. Hans

    Hans Moderator ISPConfig Developer

    You told me that you can send mail within your LAN.
    So are you really sure if the portforwarding for port 25 TCP within your router has been setup correctly?

    What is the output of:

    netstat -tap | grep smtp
     
  7. westlc01

    westlc01 New Member

    Yes I can send mail within the LAN. And I have pointed the DMZ to the server, as well as portforwarding port 25 to the server...

    netstat -tap | grep smtp
    tcp 0 0 *:smtp *:* LISTEN 4282/master
    tcp6 0 0 *:smtp *:* LISTEN 4282/master

    Hope it sheds some light
     
  8. westlc01

    westlc01 New Member

    Well I think I've solved most of the problem. I realised I had set up an mx record for mail.test.com but not an A record for mail.test.com (only for test.com) Fixed that and I can send and recieve mail.

    I still can't telnet to external IP on port 25, so I am not sure what is going on there. But thats for another night...

    Thankyou everyone.
     
  9. Hans

    Hans Moderator ISPConfig Developer

    It can take some time if the new DNS-entries take effect..
     

Share This Page