Discussion in 'Server Operation' started by mlucool, Jun 17, 2006.

  1. mlucool

    mlucool New Member

    I set up the ubuntu server using apache2 and did not choose to install ispconfig. How do I enable the server to accept https also?
  2. maxhub

    maxhub New Member

    did you install a ssl cert?
  3. mlucool

    mlucool New Member

    I dont think so. How do i do everything?
  4. maxhub

    maxhub New Member

  5. Hans

    Hans Moderator ISPConfig Developer

    Why not ISPConfig?

    Why not ISPConfig? It manages a lot of tasks for you. Also setup a SSL certificate for a website.

    If you have done Falko's "Perfect server" setup for Ubuntu i would give it a try if i was you.

    ISPConfig is really nice and via this forum, support is great!

  6. mlucool

    mlucool New Member

    I dont like ISPCONFIG. I tried it and it made alot of things more difficult. My main site wouldnt run php and most importanly i couldnt change the doccumentroot to /home/user_name. Plus I am only running one website.
  7. mlucool

    mlucool New Member

    I found out how to do this once you told me about what I needed. Thanks.
  8. falko

    falko Super Moderator ISPConfig Developer

    That happens because ISPConfig disables PHP globally so that it can later on enable PHP on a per-site basis. If PHP wasn't disabled globally, then all web sites would be able to run PHP scripts, no matter what you specify in ISPConfig.
    If you set up your main web site again through ISPConfig and enable PHP for it, then everything should be fine. :)

Share This Page