HTTPS\SSL Problems

Discussion in 'Installation/Configuration' started by yahooadam, Feb 2, 2008.

  1. yahooadam

    yahooadam New Member

    Hey all

    Ive got a server (Debian Perfect Setup - etch) going
    I wanted to use HTTPS on my website, so i went and made the cert in ispconfig, forwarded the port on my router and thought i would be set, obviously not

    if i try https://mydomain
    The connection to mydomain was interrupted while the page was loading.
    And if i try https://mydomain:81/login.php
    The connection to the server was reset while the page was loading.
    and in
    /var/log/apache2/error_log i get lines
    [Sat Feb 02 19:16:29 2008] [error] [client #ip#] Invalid method in request \x80=\x01\x03
    What am i doing wrong?
  2. falko

    falko Super Moderator ISPConfig Developer

    Do you have this problem only from outside your LAN, or also from within?
    What's the output of
    netstat -tap
    ? Any errors in /root/ispconfig/httpd/logs/error_log?
  3. yahooadam

    yahooadam New Member

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 *:mysql                 *:*                     LISTEN     2131/mysqld
    tcp        0      0 *:sunrpc                *:*                     LISTEN     1800/portmap
    tcp        0      0 *:81                    *:*                     LISTEN     31839/ispconfig_htt
    tcp        0      0 *:auth                  *:*                     LISTEN     2308/inetd
    tcp        0      0 *:ftp                   *:*                     LISTEN     2484/proftpd: (acce
    tcp        0      0 *:54805                 *:*                     LISTEN     2441/rpc.statd
    tcp        0      0 yahooadamserver.:domain *:*                     LISTEN     2032/named
    tcp        0      0 localhost:domain        *:*                     LISTEN     2032/named
    tcp        0      0 *:smtp                  *:*                     LISTEN     2372/master
    tcp        0      0 localhost:953           *:*                     LISTEN     2032/named
    tcp6       0      0 *:imaps                 *:*                     LISTEN     2280/couriertcpd
    tcp6       0      0 *:pop3s                 *:*                     LISTEN     2299/couriertcpd
    tcp6       0      0 *:pop3                  *:*                     LISTEN     2285/couriertcpd
    tcp6       0      0 *:imap2                 *:*                     LISTEN     2268/couriertcpd
    tcp6       0      0 *:www                   *:*                     LISTEN     8249/apache2
    tcp6       0      0 *:domain                *:*                     LISTEN     2032/named
    tcp6       0      0 *:ssh                   *:*                     LISTEN     2401/sshd
    tcp6       0      0 *:smtp                  *:*                     LISTEN     2372/master
    tcp6       0      0 ip6-localhost:953       *:*                     LISTEN     2032/named
    tcp6       0      0 *:https                 *:*                     LISTEN     8249/apache2
    tcp6       0   2520 yahooadamserver.yi.:ssh exten-halls-245.s:57387 ESTABLISHED18986/sshd: adam [p
    Is the output of netstat -tap

    I just tried https://mysite - and it worked fine - which is really weird :s (maybe it took a while for settings to propegate? i dont know)

    However https://mysite:81 is still not working (ispconfig) but this may be beacuse it needs to be setup in a different way
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    It looks as if you mix up different things. If you create a ssl enabled site, you must access it with https://mysite, so everything is correctly configured and working on your server.

    Port 81 is the ISPConfig controlpanel server, this is totally separate from the main server and you can not craete SSL sites andcerts on port 81.

Share This Page