https/SSL issues

Discussion in 'General' started by binaryrogue, Mar 25, 2009.

  1. binaryrogue

    binaryrogue New Member

    I enabled SSL on one of the sites and also created a certificate from the UI. The .vhost files for the domain created also shows correct entries for the virtualhost to listen on 443.

    Code:
    <IfModule mod_ssl.c>
    ###########################################################
    # SSL Vhost
    ###########################################################
    
    <VirtualHost *:443>
          DocumentRoot /var/www/mydomain.com/web
    Everytime when I try to restart the apache server, I get this.

    Code:
    Starting httpd: [Wed Mar 25 16:23:15 2009] [warn] NameVirtualHost *:443 has no VirtualHosts
    I'm using Fedora 9. Any ideas?
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    SSL vhosts in apache have always to be bount to a IP address, you will have to select the correct IP instead of * in the website settings.
     
  3. binaryrogue

    binaryrogue New Member

    That did the trick.
    I also forgot to install mod_ssl as well.
     

Share This Page