https redirect and ftp not working correctly

Discussion in 'Installation/Configuration' started by Sander Jansen, Jan 18, 2016.

  1. Sander Jansen

    Sander Jansen New Member

    its my first time working with ipsconfig, i used the VM from the guide: the perfect server. i changed a few things like password and keyboard layout and stuff... got about everything working but one thing is bugging me. when i make a website and say it needs to work over https, it just opens in http and not https... true that both do work but you need to type in https://[domain] and when you just use [domain] it goes to the http://

    i found a redirect option but havent got it to work.

    also, when i use wordpress (existing site) and copy it over to ipscondig it nicely loads but then when i need to update, ftp cant fiend the wordpress folder... i havent found a way to tell wordpress to look for it in /web... so im missing something here aswell?

    when i connect with ftp, ftp works fine but sftp (witch i want to use) it wont connect... it just times out before logging in?

    i havent tested e-mail and stuff yet so thats later on my list...i dont know if that all works... so it could be that i have some questions about that as well...
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Just add this:

    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
    in the .htaccess file of the website or in the apache directives field of the website in ISPConfig.

    There is no FTP login needed to update wordpress.

    Just ensure this:

    1) PHP mode has to be phü-fcgi or php-fpm.
    2) The suexec checkbox has to be enabled.
    3) That all files in the "web" folder of this website belong to the webX user and clientX group of this website. If you uploaded them by FTP, then thats automatically the case. If you uploaded them as root user, then chown all files and folders in the "web" folder to the user and group of that website (the user and group that owns the "web" folder.
  3. Sander Jansen

    Sander Jansen New Member

    I got the https:// working

    sftp still is a problem... when i connect with filezilla i get this:

    Status: Connecting with [domain]...
    Antwoord: fzSftp started, protocol_version=4
    Opdracht: open "[user]@[domain]" 22
    Fout: Network error: Connection refused
    Fout: Cant connect with the server
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    SFTP is not FTP, SFTP is SSH. Choose FTP over TLS in filezilla if you want to use secure FTP.

Share This Page