https only works on port 81?

Discussion in 'Installation/Configuration' started by djcronos, Jul 6, 2006.

  1. djcronos

    djcronos New Member

    Hi all,

    I have the Perfect Setup install with Ubuntu Dapper and am trying to figure something out here. I installed OSCommerce and put the proper items into the Apache Directives for the register globals, but now I would like to know how to resolve SSL on other ports than 81.

    I have phpmyadmin installed, so I will be using that as an example.

    When I go to https://www.domain.tld I get a problem with it resolving the page. It resolves port 81 just fine if I pull up https://www.domain.tld:81/phpmyadmin, as well as the ISPConfig admin panel at https://www.domain.tld:81.

    Now, how do I get my website to resolve to https://www.domain.tld?

    Thanks in advance.
  2. Hans

    Hans Moderator ISPConfig Developer

    You have to enable the SSL option for the website within ISPConfig.
    If you have done so, click the SSL tab and create an certificate and save it.
    (Only one for each IP-address).
    Last edited: Jul 7, 2006
  3. djcronos

    djcronos New Member

    Gotcha - thanks for the heads up. I've added another IP to that machine and all is well.

  4. djcronos

    djcronos New Member

    Okay, still having some problems, here's what I did:

    First, I went into ISPConfig and removed the site I set up that I wanted SSL enabled for (there wasn't an option to add SSL to the already created site). I then went into /etc/network/interfaces and added the other IP address. I then went into ISPConfig again and added that IP address to the list of IP addresses available. I can ping the new IP address just fine from another machine.

    Now, here's the problem. When I go back into ISPConfig and add a new site, I select the SSL checkbox, then when I hit save it tells me:

    You cannot assign SSL functionality to this website.
    What am I doing wrong now?
  5. Hans

    Hans Moderator ISPConfig Developer

    The normal procedure to enable SSL for a site within ISPConfig is:

    Create a site, enable SSL within the Basic tab.
    Save your entries by clicking the Save button.
    Then go to the Options tab - now you will see the SSL tab to create a certificate again. After creating the certificate, click on save. That's it.
  6. djcronos

    djcronos New Member

    Hi Hans,

    Thanks for the response. Yeah it seems pretty straightforward but it wont let me do it. I've been doing what you mentioned and I continue to get this problem.

    Could the problem be because I added this IP address after I installed ISPConfig? I sure hope that wouldn't be the problem!

    I've now added two more IP addresses to this box and I get the same error:

     You cannot assign SSL functionality to this website.
    This is with both the Admin and Reseller. What could be wrong?
  7. Hans

    Hans Moderator ISPConfig Developer

    Is the IP-address for that website included in the IP-list under Management > settings?

    Did you give the website an unique IP-address chosen from that IP-list?
    I have to mention this because you only can define one certificate for each IP.
  8. djcronos

    djcronos New Member

    Hello Hans,

    Thanks for the response. I have three IPs defined for this box. Under the Settings section in Management on ISPConfig, there is one IP address in the IP Address field, and the other two are in the IP List box.

    Once the site is created, and you don't select SSL, that checkbox won't be there when you view that site again. So what I did was remove that site and try to create it from scratch (and yes, I already emptied the Trash Can, just in case). When I try to create the site from scratch, and when I select the SSL checkbox, that is when I get this error about not being able to assign SSL to this site. I make sure that I assign an IP address that doesn't have SSL already checked.

    There is only one other site I have created on this ISPConfig box, and that doesn't even have SSL enabled. I am clueless as to why this isn't working properly.

    The only thing on here that has an SSL certificate is ISPConfig itself, and that is on the first IP address. When I try to assign SSL to the 2nd or 3rd IP address, that's when I get this problem.

    Any ideas?
  9. falko

    falko Super Moderator ISPConfig Developer

    What's in Vhosts_ispconfig.conf?
    What's the output of

Share This Page