https not working after enabling ssl

Discussion in 'General' started by jdg, Mar 14, 2010.

  1. jdg

    jdg New Member

    I just setup a SSL certificate using the instructions documented here: http://www.ispconfig.org/downloads/manual_en/manual_kunde_en_src.htm#4_2_4 (setup certificate thru the ISPConfig control panel).

    After saving the new certificate (a RapidSSL certificate from clickssl), I cannot access the site by visiting https://www.domain.com. http://www.domain.com still works fine. When I try using https my browser (firefox) gives me: "Firefox can't establish a connection to the server at www.domain.com".

    I tried rebooting the server. That didn't do anything. I'm not too sure how to debug SSL problems. Any suggestions?

    Here's what I'm running:
    -ISPConfig 2.2.32
    -CentOS 5.3

    By the way, SSL does work when accessing the control panel (https://www.domain.com:81).

    Also, prior to setting up the SSL, I changed the domain name for this site. I changed it from domain.com to domain2.com (just to temporarily disable it). I then changed it back from domain2.com to domain.com.

    I noticed the symbolic link in /var/www wasn't there anymore so I manually add it (with apache.web4 ownership, web4 being this site).

    I'm not sure if that could be related to the problems or not. I just wanted to mention it. Thanks in advance.

    JD
     
  2. Ben

    Ben HowtoForge Supporter

    that https is running fine on port 81 is just reasonable, as there are two different webserver instances running with ispconfig2.

    Did you check if apache listens on port 443? (-> netstat -tap)
     
  3. jdg

    jdg New Member

    no, it's not listening to 443. httpd is only listening on port 80.
     
  4. jdg

    jdg New Member

    mod_ssl wasn't installed. I just installed it:

    yum install mod_ssl

    service httpd restart

    Everything is working now!
     

Share This Page