HTTPS For ISPConfig3

Discussion in 'Installation/Configuration' started by GoremanX, Oct 28, 2011.

  1. GoremanX

    GoremanX New Member

    How do I change the ispconfig vhost to be accessible only via https? Running ISPConfig on Ubuntu 10.04. I can't find any option for it in the control panel, or any place to put in my SSL certificate.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Download ispconfig tar.gz, run update.php script. The updater will then ask you if it shall create a ssl cert for ispconfig.
  3. GoremanX

    GoremanX New Member

    That part worked, but I still get Secure Connection Failed when I try to access ispconfig3 using https

    The ISPConfig vhost file does have the following in it:
    Last edited: Oct 29, 2011
  4. GoremanX

    GoremanX New Member

    nevermind, I had to do a /etc/init.d/apache2 reload before it took effect. I guess I assumed the update.php script did that for me.
  5. GoremanX

    GoremanX New Member

    If the ISPConfig vhost has SSL enabled, does that mean no other vhost on that server can have SSL enabled?
  6. falko

    falko Super Moderator ISPConfig Developer

    Prior to ISPConfig 3.0.4 (which will be released soon) you can have just one SSL vhost per IP address. In ISPConfig 3.0.4, you can enable SNI (Server Name Indication) so that you can have multiple SSL vhosts per IP (please note that not all browsers support this).
  7. stevegjacobs

    stevegjacobs New Member

    ssl cert for single site

    I chose having ispconfig only available at https when i installed it. I want to only have one ip address on this server and also have a signed certificate installed that will only work for (the only web site on the server that needs a cert)

    My question is, is there some way can I use the same certificate for the site as for If so, how can I set this up?

    As I said, I won't need ssl on any other site for this server - and if I do i will add more ip addrresses

  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Make a copy of the signed ssl certificate and copy it to the ispconfig ssl folder so that it replaces the existing cert and key file in /usr/local/ispconfig/interface/ssl/. Then restart apache.
  9. stevegjacobs

    stevegjacobs New Member

    Something has gone wrong. The web site has disappeared - when I go to, I am seeing only the default web page of the server, not the web site that wsa working a little while ago.
    I had a look at the site vhost file in /etc/apache2/sites-enabled, and it looks ok to me.

    and running /etc/init.d/apache2 restart gives NameVirtualHost has no Virtualhosts
    NameVirtualhost has no VirtualHosts
    Last edited: Nov 11, 2011
  10. stevegjacobs

    stevegjacobs New Member

    Till - here is what is happening..

    Something is going wrong with the implementation of ssl on this server (ispconfig 3.04 - ubuntu 11.10 on a virtual machine)

    1. I've set up a site in client1/web1 - and enabled ssl
    2. I tick it for ssl
    3. Assign the one ip address to client1 and then to web 1
    4. As soon as I save when I do that, shows root of web (It Works! page from /var/www/)
    5. I then delete the ip address from the client, and website shows home page in client1/web1/web/

    I also tried setting up this site without an ip address and when I create the certificate, apache dies and won't restart till I delete all references to ssl in sites-available/mydomain.vhost. And I know it says that you can't do that anyway.

    Any ideas? I need this done today! :eek:
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Assign a dedicated IP to the website.
    2) Enable ssl.
    3) Create a ssl cert on the ssl tab for this website.

    The detailed procedure is also described in the manual.

Share This Page