https://domain.com:8080 forbidden after upgrade

Discussion in 'Installation/Configuration' started by Saharacruiser, Mar 13, 2013.

  1. Saharacruiser

    Saharacruiser New Member

    Hi Guys,

    I have searched the forum and browsed the ISPConfig Manual (yes, I purchased a Version :) ), but could not find any answer to my question ...

    I fail to access server.com:8080 after update to actual ISPC Version.

    Environment: Ubuntu 12.10
    following Perfect Server (Apache2, BIND, Dovecot, ISPConfig 3)

    IspConf Version: 3.0.4.4 at installation,
    today updated to 3.0.5.1 via ispconfig_update.sh


    What I ran into:
    It was all going well until I updated. Now I can access sites on :80, webmin and :8080/mail... but when trying to access ISPConfig Admin Panel at server.com:8080 I get

    "Forbidden, you don't have permission to access / on this server"


    apache2/error.log:
    Code:
    [Wed Mar 13 00:32:10 2013] [error] [client 95.91.*.*] client denied by server configuration: /var/www/
    [Wed Mar 13 00:32:11 2013] [error] [client 95.91.*.*] client denied by server configuration: /var/www/
    [Wed Mar 13 00:32:12 2013] [error] [client 95.91.*.*] client denied by server configuration: /var/www/
    [Wed Mar 13 00:32:13 2013] [error] [client 95.91.*.*] client denied by server configuration: /var/www/ 

    ISPConfig/.../access.log:
    Code:
    95.91.*.* - - [13/Mar/2013:00:32:11 +0100] "GET / HTTP/1.1" 403 179 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0"
    95.91.*.* - - [13/Mar/2013:00:32:12 +0100] "GET / HTTP/1.1" 403 179 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0"
    95.91.*.* - - [13/Mar/2013:00:32:13 +0100] "GET / HTTP/1.1" 403 179 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0"
    

    anything more you might need for error analysis?

    Thanks for your help in advance!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check that the symlink in /etc/apache2/sites-enabled points to the corrcet ispconfig vhost file in the sites-available folder so that apache loads it. Then ensure that php fcgi and the apache mod_fcgi module are installed.
     
  3. Saharacruiser

    Saharacruiser New Member

    I checked all your suggestions:

    check symlink in /etc/apache2/sites-enabled - all OK
    php fcg installed - OK
    mod_fcgi module installed - OK

    Still I was not able to connect.


    .... I am back on track now, can access :8080 again but am curious if its a clean solution:


    Code:
    #  a2enmod fcgid
        Enabling module fcgid.
        To activate the new configuration, you need to run:
      service apache2 restart
    
    # service apache2 restart
     * Restarting web server apache2 
                                                                         
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
     ... waiting Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    
    
    I reinstalled apache2-suexec and was fine.

    Could you please give a short comment on this?

    Thanks!
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Is the warning still there after you reinstalled suexec?
     
  5. Saharacruiser

    Saharacruiser New Member

    service apache2 restart does not report errors anymore and I can access ISPConfig Admin Panel again.



    I am just not sure if this is a solid solution.

    It was a blind flight, I got this hint from here but have too little knowledge about apache to understand what exactly I was doing.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The solution was absolutely fine. This module should normally be active when the server was installed as described in the perfect setup guide. I'am not quite sure why it was disabled on your server as the ispconfig installer does not manage this aspect. It is likely that mod fcgi was off before you updated ispconfig and you just did not notice it as the ispconfig interface used mod_php in older releases.
     
  7. Saharacruiser

    Saharacruiser New Member

    Thanks for your support!

    So I was lucky that ISPConfig was working before update.

    ... can I mark this thread [SOLVED] somehow?
     
    Last edited: Mar 13, 2013

Share This Page