HTTPS doesn't work but HTTP is ok? Any advice?

Discussion in 'Installation/Configuration' started by Nap, Oct 15, 2006.

  1. Nap

    Nap Member

    HTTPS doesn't work but HTTP is ok? Any advice? [Solved]

    I am new to Linux, but I've been able to setup Debian Sarge as a LAMP server (on my LAN with no incoming WAN access at the moment) and have it almost working. Thanks to Falko's excellent guide. I have also installed phpMyAdmin and ISPConfig. (I have not setup any virtual hosts yet, but that's for the future.)

    I am able to access the machine via http (apache2, phpMyAdmin, and ISPConfig) and ftp. But when I try to access my server via HTTPS (for any services), I get an error message stating:
    The connection was interrupted
    The connection to was interrupted while the page was loading.

    (I am using Firefox and I'm not blocking port 443 on client or host sides.)

    In the "netstat -tap" output, there is an entry for HTTPS, so the server is listening.

    Whilst following Falko's install guide, I did all the SSL things mentioned, so I'm puzzled as to why I'm getting this error.

    Could it have something to do with the hostname, domain name and other information I entered into the certificates? Do I need to recreate the certificates?
    Or would it be something else (config files or packages not installed)?
    Is there a way of diagnosing the problem so I can get more information about what's wrong?

    Last edited: Oct 18, 2006
  2. Hans

    Hans Moderator ISPConfig Developer

  3. Nap

    Nap Member

    Thnx 4 your reply.

    I setup my ISPConfig to use HTTP, and Falko has already shown me a link (to a guide by you) that explains how to change from HTTP to HTTPS.

    When I installed ISPConfig, I was expecting something like cPanel, but I've realised that ISPConfig is a few layers below ISPConfig and is actually different in many ways to cPanel. (Is Webmin an equivalent to cPanel?)

    I am reading the ISPConfig Manual at the moment, and I'm starting to think that ISPConfig is the gatekeeper for all www (etc.) access to the server. But that doesn't make 100% sense since I am able to access the server on HTTP without having configured ISPConfig at all.

    Since I am able to browse and get the Apache welcome page, I expect that I would get the same result when I browse but instead I get the error message I showed in my opening post.

    So I don't think my problem is with ISPConfig (even though I do need to set it up), but with the whole server (unless HTTPS is only accessable when ISPConfig is setup).

  4. Nap

    Nap Member

    Just a thought that comes to mind. When I look at the status of the various services through ISPConfig, my BIND is 'offline'.
    Could that have something to do with this or is that normal when operating on a LAN behind a router/firewall?
  5. Hans

    Hans Moderator ISPConfig Developer

    I would also figure out if your Apache server is listening to port 443, which is necessary for https.

    Check also if your router/firewall do not block port 443 and that portforwarding to your server within your LAN has been setup correct.

    Bind should work normally on a server within your LAN behind a firewall/router.
    I use it myself.
  6. Nap

    Nap Member

    Thnx Hans,
    I have a feeling you are going from post to post that was raised by me.
    Thank you for your time.

    So, having fixed the DNS server (which shows running in ISPConfig now), the HTTPS is still not working. Same error as before.

  7. falko

    falko Super Moderator ISPConfig Developer

    You must set up an SSL web site in ISPConfig first before HTTPS works. If there's no SSL web site, it cannot work.

    All ISPConfig does is writing configuration files for other services, so the services can run even when ISPConfig is not up.
  8. Nap

    Nap Member

    Ok, I'm not sure what you mean.
    When I installed ISPConfig, I had an option to use HTTP or HTTPS. I chose to use HTTP. Is that what you are referring to?

    Or is there some other option in ISPConfig I might not have seen that is used to setup a SSL site?

    Do you have to choose to access ISPConfig on HTTPS to have the SSL site working?

  9. Hans

    Hans Moderator ISPConfig Developer

    If you've setup ISPConfig running on HTTPS it does not mean that all your websites are running under HTTPS.

    What FAlko means is:

    - Create a website in ISPConfig and enable SSL for that website.
    - On the options tab, cick on SSL where you can paste you SSL certificate for that particular site.

    If you have done so, you can visit that website in a browser with https:// in stead of http://

    The only limitation is that there is only one SSL per IP-address.
  10. Nap

    Nap Member

    That's done the trick!
    (I also had to change my HOSTS file to point the domain name to the right IP).

    Thank you all!


Share This Page