https does not work

Discussion in 'Installation/Configuration' started by Isterklister, Feb 6, 2012.

  1. Isterklister

    Isterklister New Member

    I have installed a new server and followed

    I have a small problem with https. I cannot connect with https (ex https://ip-adress:8080 for ISPConfig). After I have accepted the cert I will get the error "502 Bad Gateway".

    What is wrong?

    Info from log-file:

    2012/02/06 12:35:54 [crit] 20546#0: *33 connect() to unix:/var/lib/php5-fpm/ispconfig.sock failed (2: No such file or directory) while connecting to upstream, client:, server: _, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/lib/php5-fpm/ispconfig.sock:", host: ""

  2. Isterklister

    Isterklister New Member


    Hello again,
    I am not absolutely sure why it is working now but it does.

    I looked in my interfaces file and commented one line with dns info, reboot and now it is working.

    I tried to get the same error message by inserted the dns line in interfaces (network) but I cannot force the error to reuppear.

    I now did see this line in the instructrions:
    (If you get a 502 Bad Gateway error, just restart PHP-FPM and try again:
    /etc/init.d/php5-fpm restart

    Last edited: Feb 6, 2012
  3. falko

    falko Super Moderator ISPConfig Developer

Share This Page