HTTPS (connection was interrupted) problem

Discussion in 'Installation/Configuration' started by Nap, Oct 8, 2006.

  1. Nap

    Nap Member

    Can't access ISPConfig on HTTPS [Solved]

    I am new to Linux, but I've been able to setup Debian Sarge as a LAMP server and have it almost working. Thanks to Falko's excellent guide. I have also installed phpMyAdmin and ISPConfig.
    I haven't configured the postfix server other than what was outlined in Falko's guide. And don't know if Sendmail is installed. (But I'm not worried about these things atm. I'll get to them later.)

    I am able to access the machine via http (apache2, phpMyAdmin, and ISPConfig) and ftp. But when I try to access my server via HTTPS (for any services), I get an error message stating:
    The connection was interrupted
    The connection to was interrupted while the page was loading.

    Whilst following Falko's install guide, I did all the SSL things mentioned, so I'm puzzled as to why I'm getting this error. (I am sure my firewall isn't blocking https, since I can use it on other sites.)

    Could it have something to do with the hostname, domain name and other information I entered into the certificates?
    Or would it be something else (config files or packages not installed)?

    Last edited: Oct 15, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    If Postfix is installed, Sendmail isn't (and vice versa). You'll find a binary called sendmail on your system (if you search for it), but it belongs to Postfix and is called sendmail for compatibility reasons. :)

    Did you try to connect on port 443 or 81 (ISPConfig)? If 443, you must create an SSL web site first in ISPConfig.
  3. Nap

    Nap Member

    I'm connecting to ISPConfig via port 81. It works with HTTP, but not HTTPS.

    Regarding Sendmail, thnx, wasn't sure since I read in the PHP manual that the mail() function required it.

  4. falko

    falko Super Moderator ISPConfig Developer

    Then you chose HTTP during the ISPConfig installation, which means you cannot use HTTPS then.
  5. Nap

    Nap Member

    In regards to ISPConfig, is there a way of reversing that decision, without a reinstall?
    Like changing one of the config files?

    But I'm actually having this problem with HTTPS in general. Can someone give me an idea on what I did wrong during the Debian install?

    Last edited: Oct 11, 2006
  6. falko

    falko Super Moderator ISPConfig Developer

    Have a look here: http

    You need to create an SSL web site first in ISPConfig to make SSL work on port 443.
  7. Nap

    Nap Member

    Problem solved, all working.

Share This Page