HTTPS CBAND and Apache Directives

Discussion in 'Installation/Configuration' started by rvarkevisser, Feb 16, 2007.

  1. rvarkevisser

    rvarkevisser New Member

    I followed the CBAND tutorial and with some personal modifications it works perfectly for HTTP websites. BUT not with HTTPS with SSL! Somehow ispconfig uses a different config file than vhost.conf.master, because the HTTP_INCLUDE, which I moved after the variable "ServerName", is ABOVE the variable in the HTTPS section???
    Cband errors when starting Apache 2 is the result. (undefined virtual hostname)
    So who knows how to solve this ?
  2. rvarkevisser

    rvarkevisser New Member

    Solution Found

    Oke, this was a quicky. :D

    I found the solution. The SSL/HTTPS configuration isn't in vhost.conf.master but in config.lib.php. (/root/ispconfig/scripts/lib/config.lib.php)

    Go to rule 1514 "//SSL-Web schreiben"
    Here are the variables for creating the SSL website.
    Place HTTP_INCLUDES ".$web_httpd_include." below ServerName "ServerName ".$servername."".$ssl_port."", so that the bandwidth module Cband works correctly.

    It may look somthing like this.
    ServerName ".$servername."".$ssl_port."
    ServerAdmin webmaster@".$web["web_domain"]."
    DocumentRoot ".$document_root."

    After this, just change a little setting (like the ip address) in the website and change it back to the original setting.

    Now I only have to figure out how I can disable HTTP when HTTPS is enabled. I think I'm gonna use something like mod_rewrite.

  3. falko

    falko Super Moderator ISPConfig Developer

Share This Page