Httpd service not running

Discussion in 'General' started by grant-skywalker, Nov 29, 2006.

  1. grant-skywalker

    grant-skywalker New Member

    Hi all,

    Following Perfect Debian Setup and ISPConfig was the most relax setup i've ever had!

    Thanks the team who created ISPConfig and falko for Perfect Debian Setup!

    Successful installation of ISPConfig could only last for 1 day where my httpd service was "offline".

    This is the funny part, i can access my admin page for ISPConfig and other app like phpmyadmin and roundcube-webmail. Meaning that the port 81 is functioning well but unfortunately port 80 "may not" work, as i receive a lot of emails that states : WARNING: services httpd not running [as the subject title]

    This is what shows when i type netstat -ntl

    testc@debmail:~$ netstat -ntl
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address Foreign Address State
    tcp 0 0 0.0.0.0:993 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:995 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:110 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:143 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:81 0.0.0.0:* LISTEN
    tcp 0 0 10.10.10.155:53 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:8822 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN

    Can anyone point out what could be the problem??

    regards,
    Skywalker
     
  2. jnsc

    jnsc rotaredoM

    ISPConfig uses his own apache instance.

    Did you try to restart your Apache webserver

    Code:
    /etc/init.d/apache2 restart
    And if after that it's still not running look in apache's error log, and tell us what is in there.
     
  3. grant-skywalker

    grant-skywalker New Member

    Hi,

    After force restart, it was okay.

    Thanks for your input.

    This is the output screen of my error.log from /var/log/apache2/

    [Wed Nov 29 17:50:52 2006] [error] (88)Socket operation on non-socket: apr_accept: (client socket)
    [Wed Nov 29 17:50:53 2006] [notice] caught SIGTERM, shutting down
    [Wed Nov 29 17:50:58 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec2)
    [Wed Nov 29 17:51:03 2006] [notice] Apache/2.0.54 (Debian GNU/Linux) PHP/4.3.10-18 mod_ssl/2.0.54 OpenSSL/0.9.7e mod_perl/1.999.21 Perl/v5.8.4 configured -- resuming normal operations

    regards,
    Skywalker
     
  4. falko

    falko Super Moderator

    This doesn't look good, but I don't know what may have caused it. Anyway, if it's running now, you should observe it, and if it happens again, post it here.
     

Share This Page